PDA

View Full Version : G73Jh randomly getting weird, coloured, static-like pixels



Fortesque
07-15-2012, 10:59 AM
Hey guys,

I bought this laptop second hand from eBay about 4 months ago, it currently has 1 and a half years warranty left on it.

Every now and then (but not that often until now) my laptop screen would display weird moving static in various colours, depending on what colour was being displayed on the screen. The first few times it happened I was able to resolve it by reseating the RAM, but that hasn't helped this time. Now it's decided to give me blue-green static, despite what I try.

Here are a couple of examples:

10037

10038

I've tried reinstalling the video drivers, updating the BIOS, and as I mentioned earlier, reseated the RAM.

Has anyone else had this problem? And were you able to fix it, or is this something I should send away for warranty?

Thanks in advance for any replies

Dark
07-15-2012, 11:06 AM
Your laptop is on LSD

ok you should send it away to be fixed that's not normal and you dont know what damage its doing to the screen or so forth so just to be safe send it for rma

Fortesque
07-15-2012, 11:10 AM
Thanks for the advice, and speedy reply :)

Dark
07-15-2012, 11:15 AM
Your welcome but yeah TBH with you i would really get it looked at just to be safe not worth trying to fix it yourself :) even with advice as it could be a screen problem or something bigger

dstrakele
07-15-2012, 12:38 PM
It's curious you were able to resolve the issue initially by reseating the RAM. Have you tried running memtest86+ on each single stickk for 3 passes? Or seeing if you could reproduce the issue after removing some RAM?

To me, it looks more like an LVDS cable connection issue. Did you ever try reseating this cable to the motherboard?

If you connect an HDTV to your laptop, does it also display the video corruption seen on the laptop screen? If so, the issue would be related to your Video Graphics Adapter. If not, the LVDS cable would be a more likely cause.