PDA

View Full Version : Blu Ray Discs Won't Play



imno007
03-12-2011, 05:54 AM
Hi, I just got a ASUS G53JW-XT1 and I'm trying to figure out why blu ray discs won't play in the blu ray drive - I've tried three or four of them and none of them are recognized by the drive, it says it's empty. All other disc types play fine. It's been a long day so maybe I'm overlooking something obvious, but...

Any help would be greatly appreciated.

TIA!

imno007
03-12-2011, 04:18 PM
Okay, I can't find any firmware update for the Slimtype drive, installing PowerDVD 10 made no difference, uninstalling and reinstalling the drive made no difference. At this point it's looking like I'll need to submit an RMA....

imno007
03-12-2011, 04:55 PM
Installed latest Windows 7 codec pack - still no joy

imno007
03-12-2011, 11:46 PM
Bought a Maxell Blu-ray Lens Cleaner disc, ran that twice, still no luck. Looking more and more like just the usual poor manufacturing so common these days...

I think my last ditch effort will be to a clean OS install of Windows 7 Ultimate and see what happens....

Seriously, no once else here has had this problem? LoL, why do I have to be the unlucky one?

imno007
03-13-2011, 12:48 AM
Okay, following the advice of an Asus tech (in training), I did a system restore, back to the day I got it - two days ago. I really didn't want to do it since, as I pointed out to the tech, the drive wouldn't play Blu-rays the first day I got it, before I installed any other programs, but I wanted to be able to say I followed through with their one and only suggestion in case I have to RMA the thing. Just as I expected, still no luck. And now I've got a lot of updates and programs to reinstall. Thanks, Asus. ;)

imno007
03-13-2011, 03:29 PM
Formatted hard-drive, installed Windows 7 Ultimate, still no blu-ray. Unless I'm missing something, I think it's now fairly safe to conclude that this is a hardware issue. I don't suppose Asus would just send me another blu-ray drive and let me install it myself? It just really gets under my skin that I just got this laptop and now might have to send it off for wherever for weeks.....

Brian@ASUS
03-22-2011, 06:53 PM
seems like a defective blu ray...

imno007
03-24-2011, 06:52 PM
I called Asus for the second time yesterday, because I need some kind of confirmation number from them for Circuit City/TigerDirect, and I was told I have to get back to them in a couple days, to give them time to "investigate" my laptop's serial number. Apparently it's not in their database, and generates some kind of unknown error message (at least according to the phone tech guy). Unless Circuit City changed the serial number, whatever the error is has to be Asus's fault (who else?), but for now I'm refused service because of it. Talk about adding insult to injury, lol.