PDA

View Full Version : Video game double vision



maroonbunyip
07-17-2012, 11:51 AM
I have had a few of the common problems with my G75VW. No option to stop sub woofer playing noise, games not launching, i've managed to fix them all by reading help forums on this site.. but... this one seems new (or you lot have worded it differently).
Basically, all games that use a 3D world have this weird double vision. I simply cannot find out how to fix it nor find anyone else who has had this problem. Drivers are up to date and reinstalling them does not work. I am not very tech savy... as you can see, I ran out of ways to try and show what was happening and was forced to take a picture (screenshots show the game working perfectly... weird). So when you help.. small words, please?

TF2 looks all screwy (http://i.imgur.com/dCnaa.jpg)
looks this way no matter where you go in the game (http://i.imgur.com/naZoo.jpg)
close up (http://i.imgur.com/Qrq7k.jpg)
like I said, every game with 3D elements (http://i.imgur.com/zSBFE.jpg)
however, not the game's 2D elements (http://i.imgur.com/KB9gz.jpg)

any help at all would be GREATLY appreciated. I have gone through a lot of trouble with this laptop in the few days i've had it, it is quickly becoming too great of a hassle than it is worth. I am close to returning it for a replacement, but I would much rather keeping this one.

maroonbunyip
07-17-2012, 12:03 PM
SECONDS
LITERALLY SECONDS
AFTER I MAKE THIS HELP THREAD I TRY A GAME AGAIN TO SEE WHAT I CAN DO ABOUT IT
NOW THEY ALL WORK
DAYS OF STRIFE AND PAIN, RESOLVED BY SIMPLY THREATENING TO RETURN THE LAPTOP TO THE SHOP
THANKS ANYWAY GUYS, ILL BE SURE TO COME BACK IF I NEED HELP LATER ON.

this ****ing computer...

Angrybrit
07-17-2012, 12:14 PM
Sir you have pressed the 3d vision button thus enabling the 3d features, as such the pc was trying to output a 3d glasses compatible image, this button is the litle Rog (republic of gamers) logo next to the power button.

maroonbunyip
07-17-2012, 01:20 PM
have I proven the right to reproduce yet?

PILGRIM
07-17-2012, 01:31 PM
maroonbunyip , is your G75VW the 3DE model?

If it is, some of those snapshots you linked are actually the 3D Mode at work.
You'll need the 3D glasses to "really" see it in its glory.
Also, disable that floating green text by pressing ctrl + fn + alt + insert/del buttons.

However, if you wish to watch or play in 2D, toggling the ROG button next to
the power button will do the trick in-game, as what Angrybit indicated.
Alternatively, disabling 3D is done via the nVidia Control Panel >
Stereoscopic 3D > Set Up Stereoscopic 3D, or clicking "Disable 3D Vision"
in Start Menu > NVIDIA Corporation menu.