PDA

View Full Version : G75VW Wireless N not working



FreeRangers
07-20-2012, 08:07 PM
I recently bought a G75VW laptop. I did a clean install of windows 7 ultimate and downloaded all the drivers off of Asus' website. The wireless card isn't picking up my wireless N frequency. I have a linksys EA4500 dual band router. One band is wireless G and the other band is wireless N. the computer sees the G band without any problems, but it can't see the N band. Other devices can see and use the N band so I know the problem isn't with the router. I have the latest drivers from Asus' website. Any ideas why the laptop isn't seeing wireless N?

Thanks.

dstrakele
07-20-2012, 08:28 PM
Like other Dual band routers, the linksys EA4500 broadcasts simultaneous 2.4 GHz and 5.0 GHz networks. The stock wireless card in the G75VW is capable of connecting to 2.4 GHz networks only. That is why your laptop can see and connect to the broadcast 2.4 GHz network and use the G protocol on that network. Your wifi card cannot connect to 5.0 GHz networks, so it will be unable to display the SSID of your 5.0 Ghz band running the N protocol.

If you configure the router to run b/g/n (typically an "Auto" setting) or "N only" on your 2.4 GHz network, you'll be able to achieve greater wireless speeds on your G75.

FreeRangers
07-20-2012, 08:37 PM
Oh, ok That explains it. Thanks.

soulctcher
07-20-2012, 09:05 PM
I've been considering upgrading to a Killer 1202 in mine to take advantage of current wireless tech with my new router...it's a real shame that the card is on the topside of the mobo.

Rayearth
07-22-2012, 09:57 AM
I have a D-Link DIR-825 Dual Band Router but with dd-wrt software installed. The 5GHz band is turned off and the 2,4GHz band is working in N-only mode. I tried installing many wireless drivers but still cannot connect my G75 to LAN. When I change the mode to G-only I have no problems connecting.

I can establish connection with any other wireless device without any issues so this problem lies with the laptop.
My WiFi config enclosed.