PDA

View Full Version : Mouse / KB Response & Lag in Games...



Cody Bishko
03-16-2011, 06:14 PM
Hi Everyone-

My last laptop was an Asus G53 - great laptop until it died on me, except for one thing - I could not play games on it. I used to get a 1-2 second lag on my input ALWAYS on most 3D games (ie, move your mouse to turn around, and two seconds later it would actually happen). I tried and tried and tried to figure out a fix for it but eventually just gave up and accepted I wouldn't be gaming for a while (this lag even happened in the bundled Alone in the Dark I think it was). If I turned down my video settings as low as could be, including resolution, then the games were playable...

A few months back I picked up my G73JW... and it's been good other than the infamous trackpad issue, etc. I was playing Dirt2 and it runs beautifully - but yesterday I installed Just Cause 2 and started playing and was appalled when *ghasp* the damn lag was back!!! It's at least two seconds behind anything I do, including keyboard movement and mouse looking around... Dirt2 might not have the same problem because I use a PS3 Dualshock 3 for that but JC2 being an FPS I was going to KB/Mouse it... So - what's going on Asus? :(

I'm hoping I'm not the only one, although I haven't seen anyone else complaining about this issue. I did used to have keyboard lag / missed keystrokes but I've since fixed that one. Trackpad is still a little glitchy, but I'm using a wired mouse. I've uninstalled the Fresco USB 3.0 drivers because they were causing trouble, (see http://www.asusrog.com/forums/showthread.php?1934-Fresco-USB-3.0-driver-causes-BSOD-and-Printer-errors )...

I'm hoping someone can save me :'(

Cody

FoldenCaulfield
03-16-2011, 07:43 PM
I have a G73Jh and don't experience any lag in games... occasionally the missed keystroke when typing out/editing documents but that could be me just as much as the kb. Figured Id chime in and say I clean installed my G73Jh when i got it to 7pro and installed inf/chipset from Intel's website, CatalystControl from AMDs website and used chastitys guide in the stickys to fill in the rest.. Mainly using manufacturer drivers or Win7 Found and installed it and the only Asus apps i installed were power4gear, splendid, and the atk keyboard driver. Haven't played JustCause2 but FPS-wise Fallout:NV Mafia2 and the Crysis2 demo were all flawless.

Edit: my trackpad was a little glitchy when multitouch features were enabled but I never used it so I disabled it in the mouse properties, and its been fine. I generally game/use the laptop with a Logitech M305 which I didn't think would be as good as it is, but the egg had it for $20 and free shipping right when I was looking for a nano receiver wireless mouse that matched the laptop (rubberized/black plastic) it tracks on my leg, couch, table, desk, blankets anything and is very responsive.

Chastity@ASUS
03-16-2011, 11:25 PM
Hi Everyone-

My last laptop was an Asus G53 - great laptop until it died on me, except for one thing - I could not play games on it. I used to get a 1-2 second lag on my input ALWAYS on most 3D games (ie, move your mouse to turn around, and two seconds later it would actually happen). I tried and tried and tried to figure out a fix for it but eventually just gave up and accepted I wouldn't be gaming for a while (this lag even happened in the bundled Alone in the Dark I think it was). If I turned down my video settings as low as could be, including resolution, then the games were playable...

A few months back I picked up my G73JW... and it's been good other than the infamous trackpad issue, etc. I was playing Dirt2 and it runs beautifully - but yesterday I installed Just Cause 2 and started playing and was appalled when *ghasp* the damn lag was back!!! It's at least two seconds behind anything I do, including keyboard movement and mouse looking around... Dirt2 might not have the same problem because I use a PS3 Dualshock 3 for that but JC2 being an FPS I was going to KB/Mouse it... So - what's going on Asus? :(

I'm hoping I'm not the only one, although I haven't seen anyone else complaining about this issue. I did used to have keyboard lag / missed keystrokes but I've since fixed that one. Trackpad is still a little glitchy, but I'm using a wired mouse. I've uninstalled the Fresco USB 3.0 drivers because they were causing trouble, (see http://www.asusrog.com/forums/showthread.php?1934-Fresco-USB-3.0-driver-causes-BSOD-and-Printer-errors )...

I'm hoping someone can save me :'(

Cody

Download the Keyboard / Trackpad Fix package on my Driver Reference Sticky Page and use BIOS 205 + ATK Package 1.0.0008 + Synaptic Driver included