View Full Version : USB ports all stopped working

07-24-2012, 02:19 AM
I am having trouble with my G75V laptop. When I got home from work tonight and booted into Home Premium 64-bit, my ASUS gaming mouse wouldn't respond and the ASUS logo on the top would blink and go out. I moved it from the USB 2.0 ports (right-hand side) to the left-hand USB 3.0 ports and had the same experience. I tried a USB flash drive and got no response. Every USB device I tried had the same no response.

I tried un-installing the USB devices and letting Windows re-install them. No joy. I booted into my work partition (Windows 7 Pro) and the mouse lit up and was working. Leaving it plugged in and re-booting back into Home Premium, I watched as the OS started and the logo on the mouse went out.

So, it's definitely the OS. But how to fix it is the question. Does anyone have any ideas? It was working perfectly this morning before I shut down and went to work. I have ASUS Live Update un-installed, so it couldn't be a screw up from it.

07-24-2012, 10:37 AM
reinstall usb quick charge driver --> solves the problem