PDA

View Full Version : Strange Freeze on ASUSG74SX, please help!



Zydot
08-03-2012, 03:10 PM
I have an ASUS G74SX-A1 model, it's only 6 months old and so far it's been running great. When i bought it, I did a fresh install and read through the drivers, apps post and it was really helpful. Lately i have been getting a strange freeze, it happens randomly, the computer will start to get laggy/slow to a point where i can't open any applications or do anything, but i can still see the desktop, just nothing responds. I waited to see after a few minutes and still not responding, but it doesn't give me any error messages or anything so i have to press the power button to turn it off. I don't know a time frame of when it's going to freeze, but it has only happened when I'm on the internet surfing. I tried different browsers, running ccleaner, that scan error checking, disk defrag, anti-virus and it still happened after a couple of days.

Then i ran DPC latency checker and it says to disable/re-enable each driver, after doing so it seems my wireless network adapter and ethernet card are getting high latency. I installed the latest drivers for them and still shows a similar latency as before. Right now i just run the computer with the wireless adapter disabled and just use my ethernet port with the cable directly to the modem.

So far so good, but my network card showed a bad latency before, I'm wondering if eventually it will lock-up again or is just some conflict that the wireless adapter causes. It appears the wireless adapter is not good according to several post here.

I'm wondering what i should do next?

dstrakele
08-03-2012, 03:50 PM
1) What make wireless adapter is installed in your G74SX?

2) What version wireless adapter driver is reported in Device Manager?

My suspicions are you have an Atheros wireless adapter running a driver version prior to 9.2.1.432. If this is correct, I recommend you uninstall your current Atheros driver, REBOOT into Safe Mode, and install Atheros driver version 9.2.1.470 ( http://dlcdnet.asus.com/pub/ASUS/nb/Drivers/WLAN/WLAN_Atheros_Win7_64_Z921470.zip).

Zydot
08-05-2012, 06:13 PM
My device Manager report a 10.0.0.55 version of my wireless network adapter. My wireless is an Atheros AR9002WB-1NG. I installed the latest driver for Atheros from station drivers.

My Network card is an Realtek 8168, i also got the latest driver for it 7.61.612.2012.

Right now I'm just running using the realtek network card.

Also i did the safe boot mode and used driver swiper before installing these new drivers.

dstrakele
08-05-2012, 06:40 PM
If DPC Latency Checker shows a decrease in latency when you uninstall 10.0.0.55, I recommend you backrev to 9.2.1.470.