PDA

View Full Version : Wifi Issues with G55 compared to old U52F



Mkrevald
08-04-2012, 04:14 AM
I ordered my new G55 from Best Buy on August 30 and just received it today as a replacement to my U52F which is about 1.5 years old. I booted it up, set it up, and connected to my home connection, and noticed the wifi was running awfully slow (between 70 and 200 KBps) on the G55. I figured that it could have just been an issue with the router so I reset it. After I reconnected I still had the slow connection, so I tried to see if my original U52F was having the same issues, but it's running at about 2 MBps while the G55 continues to hardly break 150 KBps consistently. I've since tried it with 2 other laptops and the household and all of them can keep their connection speeds at their usual while the G55 keeps running slowly. I don't know what's causing this or what I should do to troubleshoot any problems, can anybody give me any advice?

Mkrevald
08-04-2012, 04:22 AM
Also, the G55 has an Atheros Wireless Network Adapter and the U54F has an Intel: Centrino WiMAX 6250.

dstrakele
08-04-2012, 06:57 AM
Are you getting an "excellent" WiFi signal strength?

Is the Atheros wireless adapter using "N" protocol?

c_man
08-04-2012, 07:15 AM
How is the signal? I've said this before, the reception is not that great on Atheros compared to my XPS Centrino whatever model it has, I always forget.

With good reception I had ~8MB/s.

Mkrevald
08-04-2012, 01:46 PM
My connection fluctuates between 4 and 5 bars throughout my house on the G55, but next to the router it stays at 5 bars, however it still only gets about 200 Kbps.

I do have an N router (I forgot to mention that previously), how would I go about changing its protocol to N?

Mkrevald
08-04-2012, 01:56 PM
In terms of connection speeds I get about 16 Mbps from my room and 18 Mbps next to the router on my U52F, while the G55 only gets .8 Mbps and 1.2 Mbps from my room and next to the router respectively.

dstrakele
08-04-2012, 07:50 PM
Right-click on the Wireless Icon in your System Tray to display the Wireless Networks. If you mouse over your Router's SSID, a popup dialog will appear. The "Radio Type" will display the protocol of the connection.

If it is NOT "N", launch Device Manager, right-click on your Wireless Network Adapter device and choose "Properties" from the popup menu. Select the "Advanced" tab and confirm the "Wireless Connection Mode" is set to "Auto".

While you're in "Properties", go to the "Drivers" tab to see what Atheros driver version you're running. Uninstalling the driver, REBOOT, reinstalling the current (or most recent) driver for the device would be the next step.

Mkrevald
08-05-2012, 03:27 AM
I checked the radio type like you said, and it is 802.11n, so that isn't the issue I assume. I checked the advanced tab in my wireless adapter's driver anyways, and there was no choice to change any wireless network mode.

I uninstalled the driver afterwards and rebooted my G55, connected it to my router via ethernet cord and downloaded the latest driver, but it still doesn't get over 200 kbps.

Thank you for replying by the way, it's nice to see someone out there is willing to help. :)

(Additional information edit)
I upgraded the driver from 9.2.0.469 to 10.0.0.54, if that matters at all.

Mkrevald
08-05-2012, 12:27 PM
I tested the wifi at my girlfriend's house, and it's getting about 25 Mbps, which is about what I'm getting at my house. I suppose it's a specific issue with the G55 with my N router at my house, because both of my notebooks worked well here. I'm going to look into any differences between the routers and see if I can change anything about the one at home.

dstrakele
08-05-2012, 02:32 PM
Try configuring your router to use channel 1 with WPA2-Personal Security and AES Encryption.

You can also try deleting your current Wireless Network on your laptop in "Manage Wireless Networks" and then recreating it by connecting to it again.

Mkrevald
08-06-2012, 05:02 AM
I tried the router settings you suggested, and while it was already using WPA2-Personal Security and AES Encryption, the router was using channel 6. I changed it to channel 1, which inSSIDer said none of my neighbors were using. Although the improvement from changing it was minor, I'm getting just over 1 Mbps in my room now on my G55.

I also tried to delete my wireless connection and remake it, but it didn't do anything over what changing the channel did.

dstrakele
08-06-2012, 02:29 PM
Are you using the same server for your speed tests in all cases?

Mkrevald
08-06-2012, 11:18 PM
In the case of both my girlfriend's and my houses, I've been using speedtest.net for all tests thus far, and it's been accessing the same server for all the tests since I've received the G55. Do you think that it is more likely a router issue than an issue with the G55?

Edit: I checked my girlfriend's router out, and it says that its radio type is 802.11g compared to 802.11n that my house's router is using. Could my wireless adapter in the G55 be having issues with N routers?

Mkrevald
08-07-2012, 05:13 AM
I just got home, and the first thing I did was change my router's network mode from Mixed to Wireless-G only.

I'm happy to say that my results on speedtest.net are now at the same level that my U52F was getting, about 20 Mbps.

I don't know why I had to set it to g, but it worked. I wouldn't have found this solution without you, I'm very grateful for your help through this! If I could add more than 1 reputation right now I would, you're more than deserving of it.