PDA

View Full Version : What is with the G75 microphone?



BrandeX
08-08-2012, 05:46 AM
It's completely worthless for me, unless there is some setting I am not seeing which should be changed. Even with the boost maxed out in Windows properties, I have to shout at my screen for it to pick up anything.

Is there anything that can be adjusted besides the regular properties window to improve the sound reception?

aaronmtth
08-12-2012, 07:28 AM
same thing is happening to me...my friends kept telling me to stop "whispering" when i am talking normally.
I couldnt find a solution other than using a gaming headset .___.

BrandeX
08-15-2012, 08:57 AM
Due to lack of response, I am guessing either most people have never tried the built-in mic, or only 2 people ever had this problem. :confused:

rewben
08-15-2012, 09:27 AM
just recorded my own voice with the built-in microphone (no shouting, just talk normally). it works, loud and clear.

Hifonics
08-28-2012, 02:58 AM
I am getting the same issue with skype. I have been trying everything and it is also picking up alot of background noise.
It doesn't sound that bad when you test it yourself but everyone on skype tells me it sounds like crap or its too quiet. I'm testing the new driver release though I doubt thats gonna help.

BrandeX
08-28-2012, 09:41 AM
Yea, I never found a solution other than to plug in a different mic because this one is unusable atm.
/facepalm

Hifonics
08-29-2012, 04:31 PM
I fixed the microphone issue for me.

What I did was opened up the device manager and remove the sounds drivers. both Nvidia and VIA and restarted the computer. Installed the Nvidia beta version and then restarted the computer again and reinstalled the newest VIA and now it sounds much better.

Boldfist
10-02-2012, 06:19 AM
Anyone ever figure this one out? Or does the mic just completely suck on these G75's?
I recorded myself on skype and I can hear myself but there's always a buzzing/feedback noise behind my voice that everyone complains about.

finalhour
10-03-2012, 02:47 PM
I'm having the same issue...ish....on skype I'm told that there's an annoying "beeping" noise that people seem to hear coming from my mic/computer. It's always present, and didn't change with the VIA update(s). Anyone else having this? Is it feedback maybe? I think it happens regardless of whether I use headphones or my built-in speakers.....

Valandil_Flast1988
01-22-2014, 02:01 AM
Could I get the links for the drivers you used?

Boldfist
01-22-2014, 03:08 AM
Mic just sucks. You'd think buying an expensive gaming laptop the mic and subwoofer would be decent. Anyway, buy an external headset/mic and that should fix your issue.