PDA

View Full Version : Asus G75VW - Ram running in 1333MHz



Canson
08-13-2012, 05:37 PM
Hi guys.

First of all i have to say i am new to this forum and i already love it. Much info and great people here:o

I bought my ASUS G75VW 17.3" Full HD GeForce GTX660 2GB,Core i7-3610QM,6GB RAM,500GB HDD,DVD±RW,BT,W7H
some days ago and i love it. What a beast. Its a monster really. I am really happy with it right now.

But i got a problem with the ram memory.

The laptop has 6gb and they did run in 1600.
Now i bought 2*4GB DDR3 SO-DIMM 1600MHz Corsair Vengeace.
This one to be exactly http://www.inet.se/produkt/5315261/corsair-4gb-1x4096mb-cl9-1600mhz-so-dimm-vengeance


So now i got total 14GB Ram. But they run now in 1333MHz:(

Is this normal?
Cant the Asus G75 handle 1600MHz speed when all slot are used?
Or is it because the ram inside motherboard has CL11 latency and the Corsair has CL9 latency acording to CPU-Z info.


Sorry for my bad english. I am from Sweden:)
Anyone got some of this ram?

c_man
08-13-2012, 05:54 PM
I'm not sure if G75 can. Take a look here http://rog.asus.com/forum/showthread.php?20084-Adding-RAM-to-G75VW-BBK5/page3

G55 can, G75 can't. But again, all modules are different combinations. We should get those Kingston + Hynix in a G75 to see how that works.

Again, I don't have Hynix at all in G75, but Elpida.

G55 has something interesting as well that my G75 does not. Read http://rog.asus.com/forum/showthread.php?19755-BIOS-Performance-settings&country=&status=