View Full Version : G55VW Keyboard Backlit not working BOUGHT TODAY!!!

08-18-2012, 12:19 PM
So i bought my ASUS G55VW today and I liked the keyboard backlit but after i closed the lid and moved it to my room the backlit does not work. I DO NOT I UNDERSTAND HOW THIS HAPPENS. Pressing fn + f3/f4 no longer brings up the brightness up/down message. Please give me instructions i am no good with understanding.

08-18-2012, 01:15 PM
does any of the other fn command work ?

08-18-2012, 01:44 PM
does any of the other fn command work ?

Yes e.g. the screen brightness (fn + f5 and f6)

08-18-2012, 03:06 PM
Anybody can access the BIOS, Korky.

08-18-2012, 04:34 PM
It's a known random bug. It should work again after a shut down. At least what I've tested worked like that.

If yours does not, do a BIOS reset (well, kinda, load default settings). Make sure you have the latest (209). Also reinstall the drivers for keyboard.

08-18-2012, 07:35 PM
The failure of the G55 keyboard backlight to resume after sleep (see http://rog.asus.com/forum/showthread.php?18644-Problem-with-backlit-G55/page2) is different from @Korky's keyboard backlight issue. In this case, the backlight functions normally after a reboot.

I suspect the problem resides in the version ATK Package drivers, but this is only a guess at this time.

I recommend you PM MarshallR@ASUS in this forum to open a case.

08-19-2012, 04:20 AM
wonder if uninstalling the atk drivers and using the g75 version

also you can disable sleep mode and hibernation. always have believed its bad on the drives

08-19-2012, 07:18 AM
Tell me if there is a light without the drivers. I saw this difference between G55 and G75. G55 has no light without drivers. G75 has light even without drivers. Thus in Linux I have light on G75, but none on G55. This might mean that G55 has a different BIOS setting. But not just one.

01-30-2014, 04:45 PM
Hy guys.

Just got my G55VW back from the service area (my Motherboard was replacerd)
All works ok.... but surprise ... keyboard lights are not working...

The bord came with 2.17 BIOS ....
After reading this thread i dowgraded to 2.09 ... still no lights
Got it to 2.14 ... no lights....
Back to 2.17 ... no lights ....

I went back to the ASUS service area and in 30 sec they fixed it.... :eek:
Apparently some new motherboards came with the option disabled in the BIOS (WE CANNOT SEE IT)
Baseqly the guy ran a bootable USB dos stick and ran a file.
Everything works fine now :)
I don't recommend flashing your BIOS unless you know what you are doing !!!!!