PDA

View Full Version : Phoebus after a clean install of Windows 7



Jandenengelsman
08-19-2012, 12:19 PM
Hi Guys,

After struggling a while with all the options and old/new drivers, I wasn't still that happy with the sound of the Phoebus.

So I decide to give my system a new clean Windows 7 install, and now it sounds AWESOME!! The sound is crystal clear and very powerful, I even don't need the higher gain option anymore for my 50ohm headset.

So this is what i did:
-First make sure the bios version is up to date.
-than DISABLE the ONBOARD sound card in the bios.
-Install Windows 7, and get ALL the Windows update's FIRST.
-Than install the correct chipset, sata, network and video drivers. Do NOT install the ONBOARD audio driver!!!
-At last install the Phoebus with the latest BETA version 7.0.1.20
-Now the system is complete up and running and the sound is really amazing!! Very detailed, clear and powerful!
(Don't use Dolby HT and all the other surround crap, when you have a good surround set or some good headphone's!)

(Only mismatch I got is in Internet Explorer 9, with Adobe Flash Player 11 (11.3.300.271) It's playing stereo sound like multichannel sound!)

Cheers!!!

HiVizMan
08-19-2012, 09:18 PM
Thank you very very much for this post. Good advice mate.

DTHCoCo
08-20-2012, 01:49 PM
I do this with every major hardware change, seems common sense to me. Windows can cause many problems and that's why a fresh install is always best.

Myk SilentShadow
08-20-2012, 01:54 PM
Hi Guys,

After struggling a while with all the options and old/new drivers, I wasn't still that happy with the sound of the Phoebus.

So I decide to give my system a new clean Windows 7 install, and now it sounds AWESOME!! The sound is crystal clear and very powerful, I even don't need the higher gain option anymore for my 50ohm headset.

So this is what i did:
-First make sure the bios version is up to date.
-than DISABLE the ONBOARD sound card in the bios.
-Install Windows 7, and get ALL the Windows update's FIRST.
-Than install the correct chipset, sata, network and video drivers. Do NOT install the ONBOARD audio driver!!!
-At last install the Phoebus with the latest BETA version 7.0.1.20
-Now the system is complete up and running and the sound is really amazing!! Very detailed, clear and powerful!
(Don't use Dolby HT and all the other surround crap, when you have a good surround set or some good headphone's!)

(Only mismatch I got is in Internet Explorer 9, with Adobe Flash Player 11 (11.3.300.271) It's playing stereo sound like multichannel sound!)

Cheers!!!

Cheers for this, though it's odd you had so many problems with it sounding right. I used the onboard on my CHVF until I got my Phoebus, installed no worries using the original drivers from the DVD. All I did was just disable the onboard first then unistalled the drivers, shutdown. Installed my Phoebus then installed the drivers and have had no problems since :) but i'm glad to hear you're enjoying the card..I love mine!! :D