PDA

View Full Version : Asus ROG GX900 mouse problem



halimsideek3
08-26-2012, 02:21 PM
Guys,

I got asus g74sx and with it came an asus ROG GX900 mouse. The problem i am having now is that the ROG mouse is behaving oddly and driving me crazy. The cursor keep jumping left right up and down at random even when you are not touching the mouse at all. I tried updating the atk files, synaptic touch pad driver (which seem to temporarily fix the problem) and also updated the bios. However the external mouse is driving me nuts. Please let me know if u guys got any suggestion or solution to fix this mess.

:mad:

PILGRIM
08-26-2012, 03:09 PM
Try to download the GX900 driver here: http://www.asus.com/Peripherals_Accessories/Keyboard_Mouse/GX900/#download
(if you haven't done it yet).

chrsplmr
08-26-2012, 03:17 PM
I suggest you go into mouse settings, the sensitivity/speed settings may be way too high.
Even though you say you are not touching the mouse, gaming mice are very sensitive to the
slightest input .. such as fan vibration or the least little bump of the desktop when too high.
Some have a locking/unlocking wheel .. secure that unless scrolling...ect.

see if this helps ..

edit: same time post, didnt mean to sound like i step'd over
brotherPilgrim to say above .. yes indeed, when there is a specific driver.,try that.first.c.

halimsideek3
08-27-2012, 02:28 PM
i have downloaded the driver but i am not sure if the driver is installed correctly as it is stated as HID compliant mouse. Should the device manager say something like ASUS GX900 instead? I am really screwed up now :mad: . I even got 1 missing driver on my device manager that nothing can identify. Not even drivermax. I am totally lost now. Let me know if there is any way to check what driver that is missing.

dstrakele
08-27-2012, 03:05 PM
What is the name of the device that indicates a driver not installed in your Device Manager?

halimsideek3
08-27-2012, 03:13 PM
it is an unknown device thats all. I tried to read from driver details but it also didnt give anything. It only give me an error message " no driver files required or loaded for this device' .

PILGRIM
08-27-2012, 03:56 PM
I have the ASUS GX850, and it's also registered in Device Manager as HID-compliant mouse.
Though it has a driver update available, I haven't updated it for the reason that it's working well.

Did that "unknown device" appeared only after you installed the mouse driver?
Would it be gone if you uninstalled the mouse driver?

If you've checked on chrsplmr's suggestion, any changes so far with your mouse's behavior?

halimsideek3
08-28-2012, 09:10 AM
i have tried it. However i am not sure if the mouse is even installed properly. I dont know since when did the missing driver appeared but even if i delete the driver and rescan without connecting the mouse it is still detected. This is driving me crazy. Do any of you know how to install the mouse driver manually? I cant find the driver anywhere.