View Full Version : G73JW-3D goggles wont work?

04-28-2011, 01:35 AM
Hi i have a G73JW-3D notebook, is brand new, just 1 month... everything was working fine, but i had to reinstall some nvidia drivers because it was "lagging" my internet browsers. I manage to solve it, BUT now my 3D goggles wont "connect" to the notebook... let me explain better. MY 3D works, on all games and stuff, the goggles show that they are turned ON (green light), BUT neither the little 3D sign above my screen nor the glasses are ON... its very wierd, i have tried everything, but nothing, its like the 3D isnt connecting to my goggles... i really dont know what to do...

Please if you can give me an answer i will appreciate it... i mean i had this notebook for a month, and this happens =(

Thank everyone in advance.

04-28-2011, 01:57 AM
Ok just updating, i reinstallled all drivers again, and now my internet browsers are lagged again... and the problem hasnt been solved... But i think it has something to do whit the Emitter, wich doesnt seem to be working even after i installed the nvida driver, wich had the 3D vision packages.

Please help.!

04-28-2011, 03:19 AM
You should be able to stop the lagging when 3D mode is disabled. Alternatively you can go into the browser settings and disable hardware acceleration. Unfortunately I don't know how you can fix the connection issue.

04-28-2011, 02:29 PM
thanks for the info, i manage to solve it, after reinstalling every video driver again... dont know why didnt worked the first time...

05-07-2011, 09:06 PM
how did u do? i just downloaded the newest nvidia driver but still no luck :(