PDA

View Full Version : G74SX - Intermittent SSD recognition by BIOS



PythonesqueSpam
08-27-2012, 06:15 PM
I bought my G74SX Notebook with a Seagate Momentus XT 500Gb Hybrid hard drive.
Straight away, I installed a Corsair Force 3 120Gb SSD as the primary drive and installed windows to it with no problem.
The Seagate then became the 'data' drive in the secondary bay connected by a circuit board and ribbon cable.
This worked perfectly for over six months with no problems at all.

A few weeks ago I received two ADATA S599 128Gb SSD's as gifts and I've been reinstalling Windows 7 64Bit on them using either IDE or AHCI settings in the BIOS. I've also been booting with either MBR and UEFI activated in order to compare setup configurations.
After around 48 Hours of this work, the detection of the SSD's became intermittent.
Sometimes both are detected, sometime one and then none are found.

Just in case the Laptop BIOS had become corrupted, I reflashed it and reset the settings to default, but the symptoms still exist. The BIOS is at version 203.

I swapped drive positions to see if the behaviour is connector related but the symptoms stay the same.
The original Corsair, Seagate and optical drives are always detected as normal.
This seemed to point to the SSD's being at fault, especially when the SSD in the secondary bay stopped being detected at all.
I tested them in a Desktop machine and they are recognised straight away and operate normally.

To diagnose further, I:

upgraded the firmware for both SSD's to latest version (356) from the desktop.
placed one SSD with the original 500Gb drive as the secondary drive.
made the 500Gb HDD the primary drive and an SSD as the secondary one.
tried both IDE and AHCI with clean windows installs and the latest drivers.
downgraded the SSD firmware back to previous version (342) and retested.



The bottom line appears to be that detection of the SSD's by my G74SX is intermittent.
Detection of an Adata SSD by the primary drive bay seems to be 50% of the time and when not detected, I usually reboot a couple of times for the SSD to appear in the BIOS. Once the SSD in the primary bay is detected by the BIOS, it operates perfectly with Windows and other operating systems seeing it normally.
For the Secondary Bay an Adata SSD is almost always (95%) NOT detected.

Any suggestions or help would be appreciated.

dstrakele
08-27-2012, 06:41 PM
You've done some decent troubleshooting. As far as SSD Firmware working with the G74SX BIOS v. 203, it appears Corsair has got it right and ADATA still needs some work.

Have you contacted ADATA Technical Support? They may be able to offer you a more recent firmware version than you were able to obtain.

If you look at other SSD brands that others in this forum have reported as working successfully on the G74SX, the problem appears to lie with ADATA.