PDA

View Full Version : Boot from USB- Wat?



Ruin
08-30-2012, 04:08 AM
Heya,

I own a g75(woo) and for some reason it has been having issues booting from a USB drive. Ideally I'm trying to boot from a 16gb 3.0 stick that has PartedMagic on it to edit my SSDs partitions to install linux. I have done stuff like this in the past with this notebook, I have installed windows 7 from a bootable flash drive to my SSD and I had also booted with parted magic and linux on flash drives. UEFI is enabled.

I have tried multiple flash drives, including the one from which I installed windows 7 which theoretically work. I have also tried multiple usb ports.

When I do try to boot it from the 3.0 drive from the ports on the right it just freezes, no matter what stage of booting, until I remove the drive.

Y U NO WORK, G75?!

Thank you in advance for any help/experience provided.

Myk SilentShadow
08-30-2012, 04:15 AM
I recently tried using PM on a stick a couple months ago when I rebuilt my OS and for some unknown reason the damn thing just wouldn't work. And since I don't know much about it all...I just ended up burning it to a DVD and went that way lol...So yeah, I got lazy :p lmao :cool:

c_man
08-30-2012, 06:58 AM
Try to change USB legacy from Auto to Always enabled or something like that and see how that works. Also try to disable UEFI boot, but after you try that legacy thing first.

Clintlgm
08-30-2012, 08:47 PM
I came across a setting somewhere that enables USB 3.0 In the BIOS mode?? this wasn't a BIOS Setting. Sorry I don't remember where it was, maybe this will jog someones memory. It may have been in the settings for the Asus Charger Plus settings?? My G75 in in California for repair at present so I can't look for it.

c_man
08-31-2012, 07:15 AM
I see no such setting in Asus Charger.

At some point someone said that if you load BIOS defaults and boot just after, USB3 will act as USB2. I have never tested this, but who knows, might work.

Clintlgm
08-31-2012, 02:10 PM
Again sorry i can't remember where i came across this setting. I know In the beginning I had lots of problems with USB totally. USB 3.0 especially. Loading the latest Intel USB 3.0 Drivers, The latest Chipset Drivers. Uninstalling Asus Charger + and reinstalling it solved all my problems. Going through sorting all this out some how there was a setting to activate USB 3.0 in the BIOS? USB 3.0 is not actually much faster than USB 2.0 at least in Using USB 3.0 enclosures with Fast SATA hard drives in my experience. No where near as fast as eSATA using the same hard drives. At least on my G75 all USB ports are USB 3.0/USB 2.0 backwards compatible with USB 1. I believe the main difference between USB 2 and USB 3 is that USB 3 has 4 extra Pins and the drivers to support the extra bandwidth Paths? . Also there seems to be some issues with USB 3.0 and controllers. I know that all USB 3.0 enclosures are not equal!! IE WD enclosures had a firmware problem. So I would try a USB 2.0 Thumb drive if that works the problem could very well be with the USB 3.0 Thumb drive? I have a "Patriot Supersonic Boost XT 32GB USB 3.0 Flash Drive - PEF32GSBUSB" coming in soon. And my G75 is due to arrive back to me soon. I will test on my set up if booting to USB 3.0 will work