PDA

View Full Version : Asus X53(Sv) / K53(Sv) touchpad drivers for Windows 8 (EDTWare ElanTech Smart Pad)



SamuelDebruyn
08-30-2012, 09:38 PM
Hi

I'm a Dreamspark Premium member so I can already upgrade to Windows 8 for free. I installed it earlier this week and I love it. My Asus X53Sv works fine on Windows 8 except for two things:

1. The function keys
They actually work. But it could be better. Windows 8 shows a nice little popup when you press the volume keys on a keyboard. It works when I connect my Logitech USB keyboard but the popup doesn't show up when I use the volume keys (with Fn) on my notebook. In the metro interface I don't see anything and in the desktop interface I see the same popup as in Windows 7. It would be nice if it just worked with the default Windows 8 interface and popup.

2. The touchpad
This is a bigger problem. I can't configure my touchpad, the application to do that doesn't work under Windows 8. Vertical scrolling and pinch-to-zoom works. But I can't get other gestures to work. I really need horizontal scrolling.

Any help on newer drivers / configuration utilities for the ATK function keys or the EDTware ElanTech Smart-Pad?

Thanks in advance.

I posted this here since there is no regular notebook support forum and because you also need the gestures in games from the Windows Store.

newtechwave
09-30-2012, 03:38 AM
I was having problems with the driver working too. Then I found this:
You can install it by right-clicking the ps/2 mouse in device manager, selecting update driver and then point it to the folder where you extracted the zip from asus. So far at least two-finger scrolling, two-finger-right click and the Asus smart-sense seems to be working all right. :)

from:
http://answers.microsoft.com/en-us/windows/forum/windows_cp-hardware/is-there-a-sentelic-touchpad-driver-for-windows-8/7056ee67-1318-49af-80c6-5f11c3a15931?msgId=de80da41-130c-4ff7-87da-7888d0e934f7

It let me disable the touch-pad with the function keys (my main need). It might do what you need as well.
--I will also note, that while it seems to work for what I need -- Windows 8 complains about it when I reboot.

Rence
01-01-2013, 02:11 PM
I’ve been battling this for a while to. I had been waiting for updated drivers etc. Today (12/31/12) – I went through and updated all my drivers to the current ones. Still no way to configure Smart Gestures. Then I found it. It is a bit convoluted and in no way obvious, but it works. It may have worked without the driver updates, not sure.

Go into Control Panel – select Notification Area Icons

Find ASUS Smart Gesture Center – for me it was set to “Only show notifications” – I changed this to “Show icon and notifications”
Click OK and a new icon appears on the task bar, hover over it and it will say ASUS Smart Gestures. Double click on it and it will bring up the ASUS Smart Gesture configuration app.

Later I installed a Logitech Touch Mouse and the icon disappeared. I went into the Notification Area Icons configuration, set it back to “Only show notifications” – clicked OK, then back to “Show icon and notifications” and I got a pop up telling me that the icon wasn’t active, but would appear next time it was active. So I removed the dongle for my Logitech Mouse, rebooted and the icon reappeared. After that I was able to reinsert the dongle and the Smart Gestures icon remained, even after a reboot.

Pitcher@asus
01-04-2013, 08:10 AM
you can try K53SD or K53SM/ X53Sm driver to install, but i am not sure and guarantee it is able to use.