View Full Version : VIA audio has no advanced options

08-31-2012, 12:36 PM
I have a small but irritating problem. My microphone was fuzzing all the time and was quite annoying. I fixed this with the newest VIA HD audio deck update. However, after updating I have a problem when my headsett is connected. The speakers simply won't turn off, so the sound is coming both from the headsett and the speakers. I tried going to advanced settings, but the only option there is what language I want to use. I tried to mute the speakers, but then I cannot use the main volume control because the speakers turn on again. Is it possible to do anything about this?

08-31-2012, 12:48 PM
What driver do you have? (don't sa latest)

How did you upgrade? Since I don't have these problem for a long time now, but a lot of people still do, I suspect a bad upgrade method or corupt driver for them.

Can you put a screen with the Deck?

See my sig for sound and settings.

08-31-2012, 01:06 PM
Actually I just used Asus live update, thought that would be best. I am fairly new at this stuff. About the driver, here is a screenshot of the VIA audio deck. The problem is when I press advanced options to mute speakers when headset is inserted, there is no advanced options to do this. I attaced a photo to show what happens when I press the advance options as well.



08-31-2012, 01:25 PM
wow wow, Firstly you must delete Asus live update utility straight away my friend. It has been known to cause many many problems so i suggest you do so.

Also if you are new and want to know more about the G75 and how to keep it running good check out this thread:

08-31-2012, 01:47 PM
Ah, good to know, much appreciated! I really need to get more into this stuff, luckily I have the weekend free.

Any idea about the audio problem? It is not a very pressing issue, but annoying still. Does anyone else have advanced options in the audio deck, so that it is possible mute the speakers when the headset is plugged in? I do not know why I don't have this..

08-31-2012, 02:51 PM
Some users have reported resolving the "sound from speakers while headphones in use" issue by clean install of recent VIA driver versions. See http://rog.asus.com/forum/showthread.php?21275-ISSUE-Sound-playing-through-both-headphones-and-speakers&country=&status=.

08-31-2012, 02:57 PM
First of all the "advanced" options in Deck are the within Expert mode. What you consider to be "advanced" is merely a bad name for some unimportant settings for the app. Not your fault.

See this http://rog.asus.com/forum/showthread.php?20220-SOUND-settings-my-sound-settings-on-G75

About the bad driver install you now have, since I did the install in a different ay and I never had those problems, I can only guess what you can do now. Just DL the driver from my link and run it. You should get some options. I hope Remove will be usable. Then re-run the driver for a clean install (again I hope it will be a clean one). You can try to remove the driver from within Windows, but it's not always safe.

Now when you insert the headphones, there should be no sound from the speakers.

You should also use those EQ settings since default values are so bad.

08-31-2012, 03:33 PM
Thanks alot for the quick respond.

I did what you said and that seem to have done the trick. Now it works just as normal. Hope it remains this way and that I do not have any problems with future updates.
Other than that I have no problems with the machine whatsoever, very pleased with the purchase.

Appreciate all the help!