PDA

View Full Version : Settings for Phoebus + Tiamat 7.1 +BF3



loiphin
09-03-2012, 04:36 PM
Hi there,

I wonder if anyone would be kind enough to share their settings for a Phoebus Card + Tiamat 7.1 + BF3.

There are an aweful lots of settings to configure:

The Phoebus card itself
Windows Sound Settings
Tiamat 7.1 settings (if any?)
Settings within BF3...


Looking forward to getting my Phoebus and Tiamat 7.1. Hopefully the true surround sound will improve upon my Corsair Vengeance 1500.


Thanks,


loiphin.

slik
09-03-2012, 11:04 PM
Hi there,

I wonder if anyone would be kind enough to share their settings for a Phoebus Card + Tiamat 7.1 + BF3.

There are an aweful lots of settings to configure:

The Phoebus card itself
Windows Sound Settings
Tiamat 7.1 settings (if any?)
Settings within BF3...


Looking forward to getting my Phoebus and Tiamat 7.1. Hopefully the true surround sound will improve upon my Corsair Vengeance 1500.


Thanks,


loiphin. Set windows sound to 7.1. In Phoebus,set speakers to 7.1,then go to the Dolby PCEE page,click on "game",enable Intelligent EQ and then set it to "enhance all frequencies". Nothing more. Don't enable GX. It's there for older games with EAX. You should now be good to go. If you hear a buzz in the Tiamats,use another USB for power to the headphones. In BF 3,I have the audio set to Hi Fi. Good luck!

cutbuter4fmg
09-04-2012, 12:25 AM
I turn side and rear louder. Just high enhance in EQ and wartapes ingame.

thetruth1983
09-04-2012, 02:04 AM
Here are my settings:

BF3 set to Home cinema
Windows set to 7.1
Phoebus flex bass on (crossover @ 80hz)
Dolby PCEE off

These settings work best for me but I could never get the side speakers of the Tiamat to work in BF3. I know that the side speakers work because they work in windows sound test and also a few other games. I also have the front and center speaker volume turned a little lower than the rears since the front/center have bigger drivers.

ruffnut
09-04-2012, 02:45 AM
,then go to the Dolby PCEE page,click on "game",enable Intelligent EQ and then set it to "enhance all frequencies"

Where do I find this page, I can't seem to find it?

loiphin
09-04-2012, 12:10 PM
Set windows sound to 7.1. In Phoebus,set speakers to 7.1,then go to the Dolby PCEE page,click on "game",enable Intelligent EQ and then set it to "enhance all frequencies". Nothing more. Don't enable GX. It's there for older games with EAX. You should now be good to go. If you hear a buzz in the Tiamats,use another USB for power to the headphones. In BF 3,I have the audio set to Hi Fi. Good luck!

Thanks Slik :) :) Will try it out.

slik
09-04-2012, 12:49 PM
Where do I find this page, I can't seem to find it? Right click the speaker icon. It's at the bottom of the list.

ruffnut
09-04-2012, 01:52 PM
Right click the speaker icon. It's at the bottom of the list.

Cool, wasn't installed. Just installed it and can find it now. :)

loiphin
09-06-2012, 07:37 AM
I had a play with my Tiamat 7.1 and Phoebus last night in BF3. Sounds pretty good, amazing bass when firing your assault rifle. But some of the sounds are a bit strange. Sounds a bit tinny and almost as if you are hearing it while sitting in a large pipe. Seems to be jets and heli's as they fly over.

I setup my settings as Slik recommended, but it still doesnt sound quite right.


Any ideas??


loiphin.

slik
09-06-2012, 11:22 PM
I had a play with my Tiamat 7.1 and Phoebus last night in BF3. Sounds pretty good, amazing bass when firing your assault rifle. But some of the sounds are a bit strange. Sounds a bit tinny and almost as if you are hearing it while sitting in a large pipe. Seems to be jets and heli's as they fly over.

I setup my settings as Slik recommended, but it still doesnt sound quite right.


Any ideas??


loiphin. It's a matter of getting the settings where they sound best to you. Turn all enhancements off,see how it sounds,then try all the Game EQ pre-sets til you get it right. It may take you a while,but once you know where you like everything set,there ain't a better sound anywhere. In any game.

loiphin
09-07-2012, 08:14 AM
It's a matter of getting the settings where they sound best to you. Turn all enhancements off,see how it sounds,then try all the Game EQ pre-sets til you get it right. It may take you a while,but once you know where you like everything set,there ain't a better sound anywhere. In any game.


Thanks man. I will play with the settings and see what I can do.

OptimusCrime
03-11-2013, 06:30 PM
Set windows sound to 7.1. In Phoebus,set speakers to 7.1,then go to the Dolby PCEE page,click on "game",enable Intelligent EQ and then set it to "enhance all frequencies". Nothing more. Don't enable GX. It's there for older games with EAX. You should now be good to go. If you hear a buzz in the Tiamats,use another USB for power to the headphones. In BF 3,I have the audio set to Hi Fi. Good luck!

When you say set the Intelligent EQ to "enhance all frequencies" and nothing more, did you leave "Graphic Equaliser" "Volume Leveler" and "surround Virtualiser" on? as they were on by defult under "Game"

slik
03-12-2013, 12:05 PM
When you say set the Intelligent EQ to "enhance all frequencies" and nothing more, did you leave "Graphic Equaliser" "Volume Leveler" and "surround Virtualiser" on? as they were on by defult under "Game" I don't turn them on.