PDA

View Full Version : My Asus G75VW won't read/recognize my new 750GB SSD+HDD (Hybrid Drive)



Hrag Grag
09-04-2012, 11:25 PM
I bought a Seagate 750GB hybrid drive with my G75VW Asus. I was shocked to see 2 Hard Drive ports, i found that very awesome. So I left the stock 500GB HHD where it was and put the 750GB Hybrid drive next to it, and restarted my computer, but for some reason my Asus doesn't recognize my new 750GB Hybrid Drive. Then i turned off my computer, switched the 500GB & the 750GB and it only reads the 500GB, both port's. I bought the 750GB from TigerDirect.com , i called them, and got a replacement 750GB Hybrid Drive, and...the same results.. My computer doesn't recognize the 750GB Hybrid Drive. I'm not sure what to do anymore.

Can anyone help? Thx Ahead of time!

Zygomorphic
09-05-2012, 12:28 AM
Running EFI mode? That is all I can guess apart from something incompatible with the new 750 Hybrid. I have the 500 SSH (solid-state hybrid) in my G53SX and it works perfectly. Go figure. :confused:

Hrag Grag
09-05-2012, 12:30 AM
Running EFI mode? That is all I can guess apart from something incompatible with the new 750 Hybrid. I have the 500 SSH (solid-state hybrid) in my G53SX and it works perfectly. Go figure. :confused:

Whats EFI mode? How do i get there? should i turn it on or off? I'll give it a try, anything might help

dstrakele
09-05-2012, 03:38 AM
If you enter the BIOS (press F2 at the ASUS splash screen) and choose "Load Optimized Defaults", then Save & Exit, is the Seagate hybrid drive recognized in the BiOS?

Are you running the latest firmware available for the Seagate drive?

What is the BIOS version on your G75?

http://forums.seagate.com/t5/Momentus-XT-Momentus-Momentus/Dell-Studio-1557-Laptop-won-t-recognize-ST750LX003-drive/m-p/155199/highlight/true#M5325 reports a similar problem on a Dell system on the Seagate forum. I recommend you also post your issue there (perhaps a new thread since that one didn't offer much in the way of resolution).

Forgottenbhs
09-05-2012, 04:15 AM
Perhaps your Hybrid drive just needs to be initialized by Windows, properly partitioned and given a drive letter. I've received a couple that were not partitioned from Newegg and Microcenter before.