View Full Version : USB Port on G75VW not working

09-07-2012, 10:02 PM
I did that, one of the blue USB 3.0s still doesn't work. I put my Toshiba external HDD in and it didn't work but did light up, and work once. The one next to works fine all the time. Don't know what the issue is.

Any ideas?

09-08-2012, 02:06 AM
I don't know all my usb ports are blue. and all now work for USB 3.0. There are some issues with USB 3.0 Cables I had a couple of brand new ones that would work properly. I found that originally all my ports worked but not in 3.0 but did work 2.0, then I turned on the Asus charger Plus to activate with the computer off. And charged my GPS overnite. Well after that nothing usb worked or stayed connected. After installing the latest Chipset drivers, USB 3.0 Drivers, and then uninstalling the Asus charger plus, rebooting and reinstalling the charger plus. Everything started working correctly. USB 3.0 is sensitive about cables and physical connections that's why the use Type A Male fully enclosed connection on both ends. I have one port on the left side that is very sensitive I have to make sure the cable is fully inserted to get usb 3.0 out of it. So I just use that one for usb 2.0 stuff