View Full Version : G75VW and Bios update to version 210 big "troublems"

09-12-2012, 05:43 PM
Hi there friends,

I had just managed to have my computer exactly as I wanted, Installed all the programs I needed and formatted my old Dell XPS M1730 to put if for sale...

This morning I decided to check ASUS for any updates, just to make sure everything was "spot on"... That's when I saw that my Bios ver. 207 had been upgraded to 210; of course I had to get that upgrade, just to put the cherry on top of the icing..:( Well, I read about the procedure and downloaded the aprox. 6 mb file. Following ASUS instructions I used Winflash (in windows). It picked up the new Bios, and carried out the upgrade without any issues; actually it went like a treat (first removing the old bios, progress shown in a bar, then installing the new one, the same thing and finally carrying out a check of the new bios. finally it said everything correct, 100% done and that I should restart the computer.

Too good to be true; when I restarted, I got the following message: "Reboot and select the proper Boot Device or insert Boot Media in selected Boot device and press a key"...:mad:

After several tries I picked up my wife's laptop and started investigating. That was when I found this forum and started reading about the Bios upgrade and how to properly install it. Problem is that if I restart the computer and enter the Bios setup, it now clearly shows that the new Bios is there clearly showing version 210.

I tried using a USB flash drive and restarting the computer with F2 so I enter the Bios setup, then select Advanced and start the ASUStek easy Flash Utility and choose the new Bios from that USB flash drive I get this new message window: " Warning!! Build date is too old!! Please press Enter to return"...

I'd give ANYTHING to be able to walk back my steps and return to how it was this morning when I started my G75VW and read my emails.. but no, I can't do that and even though I have gone through most of the messages that relate to this issue, I have found none that I find can help me out here. I'd actually love to be able to recover my old Bios and be done with this, but I can't.

The G75VW is not a brick (YET), but I don't want to make any more stupid moves that could render it as that; just hope someone can lend me a hand to restore or fix this problem.

I have the two 750 HDD in a Raid 0 configuration, 12 Mb RAM, WIndows 7 Professional and tons of programs and files related to my greatest hobby, photography. I also have more than 10 games where the Nvidia graphics card works wonders... Anyway, all that is gone for the time being.

If I insert the Windows 7 installation disc it will accept it and proceed to install it if I wanted, but that would mean more than two months of hard work down the drain and many photographs and programs gone; most for ever.

Hope there is a better way out for this.

Best regards,


09-12-2012, 06:34 PM
I'll try to add a screen shot of what is now shown as I open the bios configuration

Arne Saknussemm
09-12-2012, 06:50 PM
Have you tried navigating to the BOOT menu and selecting your hard drive as the first boot option? and making sure you you are in RAID mode and not IDE....... ADVANCED menu...... sata configuration......

09-13-2012, 01:23 AM
Have you tried navigating to the BOOT menu and selecting your hard drive as the first boot option? and making sure you you are in RAID mode and not IDE....... ADVANCED menu...... sata configuration......


This is all you need to do. Go into the BIOS (F2 as it starts), select the advanced menu (press the right arrow) and then scroll down until you see something like IDE mode. Hit enter and change it to RAID. You PC should now boot.

Rule of thumb: if everything works, you don't need a new BIOS.

09-13-2012, 09:33 AM
Thanks a lot to both Arne and Marshall,

I checked the advanced bios section and on the SATA configuration I had the option to select IDE AHCI and RAID..
I chose RAID and exited with F10 saving changes.

Now the computer at least goes the next step forward showing the normal startup screen, but does not accept the RAID configuration, showing Volume 0---- RAID0(Stripe)---- 16Kb strip----- Size status 1.3 TB---- FAILED------ Bootable NO; see the enclosed picture..

I have the option of pressing Ctrl-I to configure and I get the RAID configuration screen; the recovery Raid options is greyed out and the option 1 create new partitions gives me the shivers...:(

I am also a believer that anything that is working fine should not be toched, but I had an issue that I didn't want to add here in this mess I've managed to achieve, since it seems trivial if we consider the actual situation, but I did have an issue with the computer freezing randomly (the mouse pointer would not react ASO), and will come to it once this is hopefuly sorted out.

Thanks again

09-18-2012, 04:19 PM
Since I got no reply to the latest developments, I went ahead and deleted the RAID0 and configured a new one for the windows 7 OS. Of course all my data was gone and had to reinstall everything, but eventually and as I can assure you I'm right now using my G75VW to write this message.

I must stress here how annoyed I am with ASUS for letting me get into this deep hole when I carried out the Bios Upgrade following step by step their instructions on how to upgrade to ver. 210 using the WinFlash program; it is still in their VIP and general Support technical info. Might work with non Raid0 configurations, but NOT with my factory config Raid 0.

The correct way to handle upgrades and updates should be done the same way Dell does with their customers; each customer gets a code for their computer and when they check for updates, the list will show which updates are valid for their custom built PC and which are not recommended. Right now if I enter my member data I get a list of about 40 updates for my computer, but I have no way of knowing which I should install or are recommended and which aren't . Don't need to tell you what a bad experience I had with the Bios upgrade which was a clear update just by reading the data on the tech sheet, and of course being the version I had 207 compared to the new 210, but there you go.

I will no longer search for info on the ASUS site, but come here and ask, because I'm sure I will be much better well off.

Thanks again

Spanish Flyer

09-18-2012, 05:14 PM
sad to hear that and sorry for the losses :/

although it's too late now, please do this next time (particularly in a raid-0 setup): back up your data before you do anything to your computer. it will take a while, but i think it's worth the time spent. things like bios upgrade tends to reset the settings to defaults, and raid-0 is vulnerable to that (raid-0 is not recommended in any way if you have a lot of precious data on it; but if you want to leverage on its advantages, then you have to back up your data regularly).

i've learned this the hard way too :)