PDA

View Full Version : G75 Slows down on battery while running games



rjulius
09-15-2012, 12:14 PM
Hey guys is it really normal that a G75 is running totally slow, about 5fps at its lowest and 33fps max when its running games on battery even if it is in high performance mode? and not just that the screen is blinking every 5 seconds or so when it Im running a game on battery.

I dont really want to go to the service center because they might get the warranty out of my laptop.


heres the specs

G75VW-TS72
i7-3610QM @ 2.3GHz
750gb HDD
16gb ddr3 Ram
Nvidia GTX670m 3gb

rewben
09-15-2012, 12:28 PM
gpu draws more power. playing games on battery only is not a good idea.

iBoody
09-15-2012, 12:37 PM
Hi, Even your in High Performance power plan (Power4Grear or Windows) it's adjusted to 'On Battery' mode. That means there're some power saving options and most of the process states are set to lowest when it enabled. So I mostly sure that this could e the reason your having the low fps. (hope plugged in mode works fine for you).

Simply,

TaskBar->Power Plan->More Power Options
Click on 'Change Plan Settings' -> 'Change Advanced Power Settings'
Goto each node and you will see, even you in High Performance, there're two controls one for plugged In and one for On battery
So change 'On Battery' settings equals to 'Plugged In' Settings like Maximum and Minimum Process States, Power Saving Options...etc



By this way, you will get the same performence as your in a 'Plugged In' mode. But surely will result to drain the battery quick.

Hope this is helpful...

Cecil_2099
09-15-2012, 12:46 PM
iBoody, even if you make those changes the system will still throttle itself. It's built into the system's architecture and isn't a defect.

Apexing
09-15-2012, 01:53 PM
this is perfectly normal, and how the system is designed.

rjulius
09-15-2012, 04:35 PM
thanks for the replies its greatly appreciated guys :D. i think i can still handle finding an outlet.

iBoody
09-16-2012, 02:09 PM
iBoody, even if you make those changes the system will still throttle itself. It's built into the system's architecture and isn't a defect.

but celcil, systems architecture level energy consumption controlled by it's OS power plan for each drivers. that's why they indirectly referenced to two mode options. Just try to switch to 'Battery Saving' power plan and activate battery mode when your notebook is plugged in. You'll witness the same lag/throttle.

Cecil_2099
09-16-2012, 08:38 PM
While it may be true when plugged in, the GPU acts independently of the OS power plan when on battery. Just apply the settings as you suggest and you'll see that it makes no difference if you're on battery. I'm just pointing out what I have found in practice ever since I've had this laptop from product launch.


but celcil, systems architecture level energy consumption controlled by it's OS power plan for each drivers. that's why they indirectly referenced to two mode options. Just try to switch to 'Battery Saving' power plan and activate battery mode when your notebook is plugged in. You'll witness the same lag/throttle.

mishkamba
09-17-2012, 08:34 AM
thanks for the replies its greatly appreciated guys :D. i think i can still handle finding an outlet.

here i though i am the only one having this problem.. well thanks for this thread :)