PDA

View Full Version : 3D not working on G53JW. Any help is good :D



ChainSaw90
09-15-2012, 02:17 PM
Hi, Theres a problem that I have been having for a couple of months now.

I sent my Asus G53JW-3DE for a rma with a broken jack connector a couple of months back. When it came back to me, everything was working fine except my 3D glasses. There is no stereoscopic settings to be found in the NVIDIA control panel and when I actually click on enable or disable 3D at the start menu, it does nothing at all. Furthermore, the ROG button where you control the 3D is not working aswell, All it does when i click on it is changing my screen mode between normal mode, vivid mode, gamma correction etc.

Any help with this would be of great help.

P.S i just updated to the new 306.23 update hoping it would help me but to no avail.

dstrakele
09-15-2012, 02:45 PM
Did you perform a "clean" NVIDIA install of the 306.23 driver?If you didn't, and did not have 3D drivers installed on your previous version (i.e. the one ASUS may have installed), they would be skipped in a regular 306.23 installation.

Gorman
09-15-2012, 02:52 PM
There is two G53JW sub models. One has 3d (the G53JW-3DE), the other has higher resolution (G53JW).

Sounds like the RMA guys dun goofed ;)
Check your max resolution. There are 3 types of screens used in G53JW variants;
15.6" 16:9 HD (1366x768)/HD 3D (1366x768 120Hz)/Full HD (1920x1080) LED Backlight
If you have max resolution of 1920x1080, then they swapped your laptop for a non-3d model.
If you have 1366x768 then it might still be a non-3d model, but you need to check the hardware for it.

RMA it again, tell them 3d broke when they fixed it last time.

PILGRIM
09-15-2012, 03:03 PM
Welcome!..

When you updated to the new 306.23 driver, is the Stereoscopic 3D Settings still missing in nVidia Control Panel?
I don't know what BIOS version of your G53JW utilizes the ROG button to toggle as 3D on/off.
But does your current BIOS version does that, prior to your RMA?

dstrakele
09-15-2012, 03:17 PM
That's a good point, @PILGRIM. If the motherboard was replaced to fix the connector pin, it may have an earlier BIOS version.

PILGRIM
09-15-2012, 03:23 PM
...
If you have max resolution of 1920x1080, then they swapped your laptop for a non-3d model.
If you have 1366x768 then it might still be a non-3d model, but you need to check the hardware for it...



Yeah, worst thing that could happen is if they swapped the motherboard with a non-3D one.

ChainSaw90
09-15-2012, 04:05 PM
Thanks for the reply guys.

Yes, I did a clean install of the new version. A couple of times in fact.

Gorman : Mine is still under the max resolution of 1366x768 120Hz. and yeah they might have changed the it for the non 3d model. Is there any way of checking this out?

I just gave a message to the RMA guys and hopefully they will check it out for me.

What I think happens is as what all of you have suggested that when they changed my motherboard to replace the connector pin, they might have swapped it for a new motherboard with a newer bios and that kinda messed things up because I think I have tried most of that I can and nothing seems to work :/

dstrakele
09-15-2012, 04:45 PM
So you RMA'd the laptop to get a defect fixed and it is shipped back with a new problem. Was your laptop sent to the Milpitas, CA ASUS Service Center by any chance?

PILGRIM
09-15-2012, 05:20 PM
ChainSaw90, your G53 saying the max resolution of 1366x768 at 120 Hz means good news-
your native monitor/screen is still 3D-capable.. Any resolution with lower than 120 Hz means it's a non-3D.

Now, we can narrow down the cause of the problem a bit..
Can you still remember your G53's BIOS version that was working with 3D Mode
before you had that RMA? Is the BIOS version still the same currently?
You may find the current BIOS version by typing "System Information" in Windows' Start Menu search box.
(It should be there in BIOS Version/Date.) If the BIOS version is outdated, try updating it with EasyFlash.
This may help with the ROG button functioning as 3D on/off toggle.

However, I'm still confused as to why your nVidia Control Panel doesn't have the "Stereoscopic 3D Settings",
assuming that you installed new nVidia driver version correctly. In fact, any of of the nVidia drivers
(from the stock nVidia driver that initially came with your G53, until the latest one now) should have
that 3D functionality as a choice, during installation.

Perhaps, you might want to do this nVidia driver installation procedure?:
(Disregard if you this already)

-Uninstall all the nVidia drivers in Windows Programs and Features (multiple restarts are expected).
-Reboot in Safe Mode (F8), use CCleaner and Driver Sweeper to clean previous registry remnants.
-Reboot in Safe Mode again, install the newer WHQL driver. Choose "Custom Installation",
make sure all are checked except maybe "nVidia Update". Reboot.

ChainSaw90
09-15-2012, 06:26 PM
Hi, sadly I do not know what my previous version of BIOS is. Really should have checked it out.

I will try your method later today and I just found out something really weird. I just plugged my G53 into my external display with a HDMI output and the stereoscopic settings came up in my NVIDIA control panel but when i unplug the HDMI cable, its back to not having the stereoscopic settings. and when I try setting it up with the HDMI cable plugged into my laptop, it fails to detect my built in IR emitter. All it detects is a usb IR emmiter( i dont have this ), glasses(yes) or NVIDIA Discover glasses.

Does that mean that my IR emitter is not working or when I had it back form my previous RMA, somehow they did not set it back properly?

PILGRIM
09-16-2012, 01:28 AM
Hi, sadly I do not know what my previous version of BIOS is. Really should have checked it out.

I saw the latest BIOS for the G53JW is BIOS 211. It most probably has that ROG button 3D functionality.
But the underlying fact is that except for that ROG button issue, any of the BIOS versions should at least
make 3D Mode to function..


I will try your method later today and I just found out something really weird. I just plugged my G53 into my external display with a HDMI output and the stereoscopic settings came up in my NVIDIA control panel but when i unplug the HDMI cable, its back to not having the stereoscopic settings. and when I try setting it up with the HDMI cable plugged into my laptop, it fails to detect my built in IR emitter. All it detects is a usb IR emmiter( i dont have this ), glasses(yes) or NVIDIA Discover glasses.

Does that mean that my IR emitter is not working or when I had it back form my previous RMA, somehow they did not set it back properly?

Checking 3D settings with an external 3D-capable screen (via HDMI), and finding out the Stereoscopic 3D settings were indeed installed, was good troubleshooting.
Now, the root of the problem is more or less isolated.

I remember way back- Brodyboy, the best technical advisor for the ASUS G-Series in this Forum,
has mentioned about 3D laptops having a separate tiny "3D cable/s" that connect the built-in IR emitter
to the motherboard. (Sorry, but with Brody's prolific postings, I can't seem to find that reference now..)

So, I also think that when you had that RMA, they hadn't reseated the IR emmiter to the mobo properly.
Thus, the reason why nVidia driver is acting weirdly.. Sorry to say, but set up another RMA?..

DLea
09-26-2012, 01:30 PM
I recently bought a replacement screen for my laptop, after it's been cracked for over 6 months. When I go to NVIDIA control panel the "stereoscopic" option does not show. Yes it's being read as 120hz, and I verified the part # and it is HD-3D. Here comes the kicker, when I plug in a external monitor such as my TV threw HDMI or CRT monitor threw VGA (both devices only being 60hz refresh rate) and set them as primary, the option of stereoscopic shows up!

Things I've tried:
1) I installed the old cracked screen that I played 3D on numerous of times and it did the same thing with it as well
2) reinstalled different versions of NVIDIA drivers in safe mode, didn't work
3) Run stereoscopic setup menu while 60hz was set as primary, disconnect it and setup automatically shut down
4) Run stereoscopic setup menu while 60hz was set as primary, connect ir emitter, then upon choosing glasses, only discovery (red,blue) showed and 3D display not found.
5) Reinstalled windows 7, 2 times, and did a fresh install of all drivers.

One thing I've learned, whenever I did the fresh install of windows and installed the original phy x and graphics from ASUS website, the 3D button worked on the laptop shortcut key, but after updating to the newer NVIDIA driver, it stopped working.