PDA

View Full Version : Blinking screen after installing latest GFX drivers?



Fanty
09-16-2012, 01:43 PM
I just installed the latest Geforce drivers and after booting, the screen was blinking all the time. IMage, no image, image, no image, etc. It was impossible to do something.

My only chance was the start the laptop in safemode and check "use last driver".

What could cause this and what can I do?

EDIT:
I am currently using 296.44
The problems showed when trying a 306.23

EDIT 2:
I get the same effect in 296.44, when I close Firefox. Switching off 3D complete, solves this.
But in 306.23 this effect shows up after booting and not only once like the Firefox closing, but again and again and again and never stops.

iBoody
09-16-2012, 01:51 PM
Hi, Havent you try Custom/Clean Install? If Not, boot from the Safe mode and try to Install it again with Clean Installation. That should work...

dstrakele
09-16-2012, 01:54 PM
It sounds like it may be trying to set up multiple monitors and cycling through resolution settings. Anything plugged into your HDMI or VGA ports? Check out Resolution settings.

@iBoody's clean install from Safe Mode suggestion is a good idea.

rewben
09-16-2012, 01:54 PM
please try this:

1. uninstall all related drivers about nvidia (everything; find them in Programs and Features in control panel; if there is an option for you to remove all settings, do that too)
2. reboot to safe mode (pressing f8 key for several times before the windows logo appears).
3. install the new nvidia drivers.
4. reboot normally.

good luck :/

Fanty
09-16-2012, 01:56 PM
Hi, Havent you try Custom/Clean Install? If Not, boot from the Safe mode and try to Install it again with Clean Installation. That should work...

What do you mean with "clean install"? Manually un-installing the 296.44 before installing 306.23?

iBoody
09-16-2012, 02:24 PM
What do you mean with "clean install"? Manually un-installing the 296.44 before installing 306.23?
In the safe mode, when you run the setup.exe, you will comes to a screen asking Installing Options. In here,

Select the Custom (Advanced)
Click Next-> checked every driver components (some preferred not to select nVidia update) + Select 'Performe Clean Installation'


try this out buddy...

Fanty
09-16-2012, 02:25 PM
Ok, I tried it. Now it says I have the driver installed.
But now there is a new problem:

It doesnt recognize my 3D glasses.
It asks me for 4 different kind of glasses, no option un-greys the "continue" (or whatever its name in english versions - I use a German one) may be. :(

Fanty
09-16-2012, 02:40 PM
Update:
Ok, fixed it.

I uninstalled and clean installed again. Now it works.

Thanks.

*phew*

I hate things like this.
Note to myself: If its not broken, dont fix it! ;)