View Full Version : G74SX Mouse Issue

09-19-2012, 06:20 PM
As of recent I've been having some issues. Firstly the trackpad ( http://rog.asus.com/forum/showthread.php?22870-G74SX-trackpad-is-slowly-killing-me-on-the-inside ) now its moved to the actual mouse.

While ingame the mouse clicks arent registering and I have to click more than once for it to register.
I thought it was the mouse so I bought a new wireless mouse M705 (old was M505). The problem continued. So I thought maybe there was some wireless interference, I bought a wired Razer DeathAdder -- problem persists.

I cant WADS + Click at the same time in game. I figured maybe it was the trackpad, so i disabled the trackpad and the problem continues.

I've played SC2 and TF2 for years without any issues until the last few days.

Am I missing something?? I'm losing my mind

09-19-2012, 06:40 PM
Just to make sure before I open my mouth (lol), it sounds like you have the Sentelic Touchpad, going by the version you said you updated to in your other post? (9.1).

09-19-2012, 06:45 PM
You are correct.

I have a feeling its the keyboard tho.
I cant press any key and click at the same time

09-19-2012, 06:53 PM
That's normal at first :P That really irritated me too, and what I found is that by default, the settings are set so that you can't type and move the mouse at the same time, to avoid unnecessary clicking. But that can be changed! Just as an FYI, I am using the Driver, and I haven't had any issues at all so far, other than the actual hardware of the touchpad being finicky at times. Here's how you can fix the typing/mouse movement issue.
1. You'll want to open up the Control Panel, and go into the Mouse properties, and go to the Finger Sensing Pad tab.
2. In there, press the Configure button and a new window will come up
3. Expand the Enable/Disable Pad tree
4. In the Typing Detection section, you can uncheck a box so that the mouse will work regardless of typing.
5. Also, I personally have the USB Mouse Detection box checked so that when I'm using my Razer DeathAdder, I won't accidentally use the Touchpad at the same time. Saves you from getting frustrated!

Hope these pictures give you some help!


edit: p.s. I'm at work right now, so if I don't respond back immediately I'm out doing a few tickets :P But I'll try and respond back quick to help

09-19-2012, 07:28 PM
Im assuming I need to install your version, as mine doesnt have that


09-19-2012, 07:35 PM
Ah I see, I haven't tried the in a long time, didn't realize they could have taken that away lol. Best bet would be to uninstall that Sentelic driver, restart your computer, and then install the driver listed in this topic, which has pretty much all the necessary drivers for our machine :-D


09-19-2012, 08:18 PM

I did as you suggested and as I was I remembered something.
I installed some third party software (touchfreeze) to fix my older touchpad issue. The software would automatically disable the cursor when I was typing.
Thanks man!!!

Problem is solved

09-19-2012, 08:23 PM
Awesome! Glad you got it fixed!