View Full Version : G53JW + Power 4 Gear issues

05-12-2011, 04:04 PM
Hey everyone,

I'm having issues with the power setting associated with my G53JW.

I'm using the Power 4 Gear ver. 1.1.43 provided for the G53JW on the Asus website.

It has the S.H.E (Super Hybrid engine) associated with it, however, it doesn't seem to be working properly at all. It simply keeps my CPU in "turbo" more constantly even at low frequency state. The memory is constantly overclocked to 1420mhz and my performance and battery life is actually suffering quite a bit because of this. I thought S.H.E was only supposed to overclock when it was needed, and not have the overclock in a constant state?

I looked at chastity's driver page and noticed a discrepancy between what is suggested by Asus (1.1.43) and what is posted there (1.1.37). I tried using the version hosted on Chastity's website with some luck. Initially I had access to the turbo toggle and it made everything at regular spec (mem 1333 / CPU 933 @ C1 state). However, when I restarted it reverted back to turbo mode even though turbo was not selected in the Power 4 Gear menu. After I toggled the turbo switch to on and then off it fixed it however. It's just a pain to have to CONSTANTLY do this every time I start up.

Thinking it was Power 4 Gear all together, I uninstalled the program and decided to go with windows power management. Big mistake... It kept everything in overclocked state. Even the battery saving mode!

I'm thinking that this is a bios issue associated with the G53JW. The fact that they don't give us an option to turn on / off the turbo mode in the bios like the G73 models is really a pain. If other owners could chime in with their experiences, I would be greatly appreciative.

BTW, i'm using bios 211 which is the most recent on the Asus website. Also, ever since I updated to this bios, my left ALT key stopped working.


05-13-2011, 07:52 PM
Bump for input...

05-13-2011, 08:02 PM
I'm afraid I don't know anything about your power saving options, but did you reset the BIOS to factory defaults after the update? Sometimes settings linger and cause strange issues.