PDA

View Full Version : G75 ROG 3D on/off BUTTON



TheBesieger
09-22-2012, 09:36 AM
Hello
I'm playing guild wars 2 on the G75.
When i start the game it will start auto in 3D gaming because the 3D glasses connected etc.
When i dont like to play in 3D u simple use the ROG button (next the power button) and the 3D gaming is off.
This time i use the ROG button to put the 3D gaming off , and i get back to the windows screen.
Ofc when i go back to the game the 3D gaming is on again.
I never got this before and i dint changed the settings.
Can someone help me with this problem? :)

ForCeV
09-22-2012, 07:30 PM
Currently, I have same issues like you... and it wasn't happened when I was using ASUS old graphic driver. and There was a option that you can control the 3d which means "hide stereoscopic 3d effect option." This option is good for 3d play because when you turn back to screen and go back to game again. 3D effect doesn't activate until you click a 3d on/off button.

I have no idea how to do this.. but actually know that it is related with hide stereoscopic 3d effect option. Plus I don't know why nvidia driver has disappear this option in newest drivers....

TheBesieger
09-29-2012, 11:32 AM
Seems none can help us witht his.

ForCeV
09-29-2012, 04:11 PM
Yea... It is so terrible... I would like to ask Nvidia about this issues. But I don't know how to send an E- mail to them.. Also, They have closed their forums because of renew their site... However, it takes so long time to do it.... I hate it... Do you know how to send them e-mail about this question??? If you know an E-mail address of NVIDIA, let me know....

We should ask NVIDIA., it is the way faster to ask and getting an answer...than asking this forum or Asus....

Shawnnepc
10-01-2012, 03:18 AM
NVIDIA is aware of this issue and this forum.

They'll post if a fix is made or is possible

PILGRIM
10-01-2012, 05:22 AM
Hello
I'm playing guild wars 2 on the G75.
When i start the game it will start auto in 3D gaming because the 3D glasses connected etc.
When i dont like to play in 3D u simple use the ROG button (next the power button) and the 3D gaming is off.
This time i use the ROG button to put the 3D gaming off , and i get back to the windows screen.
Ofc when i go back to the game the 3D gaming is on again.
I never got this before and i dint changed the settings.
Can someone help me with this problem? :)

Hi. I didn't know this ROG button issue for 3D mode exists even with the G75.
I have the G74, and the ROG button has the same issue as you described.
We, "3D guys", in the Older G Series forum had also discussed about this.

But to set things straight, any of the nVidia drivers have nothing to do with it.
It's the BIOS (mis)configuration that is causing it.

The ROG button is supposed to be a 3D toggle shortcut- meaning it should function
before, during, or after a 3D-capable game or video is launched. But it doesn't.
One has to go to nVidia Control Panel or nVidia enable/disable shortcuts (Start Menu), and enable 3D mode first.
Only then does the ROG button actually works- but only during in-game.

Now, when you play a game in 3D, and you decide to shift to 2D in-game, the ROG button should do it.
But the thing is, the computer is, in reality, still set up in 3D Mode.
As what you have experienced, when you exit the game and launch it again, it's still in 3D. Go figure..

Well, methinks personally for it to be only a minor annoyance.
The ROG button issue doesn't affect at all my laptop's 3D performance.
Just wished the ASUS engineers could have programmed it better- for it to work synchronously with the nVidia driver.








Currently, I have same issues like you... and it wasn't happened when I was using ASUS old graphic driver. and There was a option that you can control the 3d which means "hide stereoscopic 3d effect option." This option is good for 3d play because when you turn back to screen and go back to game again. 3D effect doesn't activate until you click a 3d on/off button.

I have no idea how to do this.. but actually know that it is related with hide stereoscopic 3d effect option. Plus I don't know why nvidia driver has disappear this option in newest drivers....

The "hide stereoscopic 3d effect option" has nothing to do with enabling/disabling 3D Mode..
It's just an option when one doesn't want 3D effects to be seen when starting a game or video.
As we know, enabling/disabling 3D has to be done by checking/unchecking the "Enable Stereoscopic 3D" box
in nVidia Control Panel, or via nVidia enable/disable shortcuts in Windows Start Menu.

I also don't want the 3D effect during game launch. So I set it to "Only while full-screen 3D programs run".

dstrakele
10-01-2012, 12:01 PM
That's a good explanation of ROG Button 3D enable/disable shortcomings, @PILGRIM!