PDA

View Full Version : Realtek HD Audio ALC269 Headphone audio problems...



kimiraikkonen
09-22-2012, 11:43 AM
Hi guys,
First off, it's really interesting to notice that Rog site index has been hacked, fortunately they seem merciful enough to let us keep our connection :)

Btw, i have some kind of irritating noise / static noise problem from headphone jack when i connect any ac powered_external speaker or any stereo headphone in my G53JW. You know most of Rog notebooks have built-in Realtek ALC2XX series codec and mine has ALC269. Here are is the problem:

-When an external headphone or speaker is connected to my G53JW's headphone jack, they're recognized just fine and built-in speakers are disabled as expected, that's OK. The problematic part is, whenever a sound file is gonna be played or an audio activity is about to happen, i hear a MOMENTARY "pıtt, dıtt, click" noise "temporarily" as if audio channel is activated and hearing the same unwanted noise after a while again as if audio channel is deactivated again and again.

Is there a kind of hardware-related audio problems on your Rog notebooks?

Note that disabling THX TruStudio and using stable Realtek driver isn't a solution as well as making Windows Audio service "automatic" didn't help. Also disabling all environment effects DID NOT help! Asus is really bad working on audio setup on their notebooks!

Any ideas?

dstrakele
09-22-2012, 01:06 PM
See if this registry edit helps: http://forum.notebookreview.com/hardware-components-aftermarket-upgrades/587521-fix-realtek-sound-popping-high-pitched-tone-squeal.html#post7617517.

kimiraikkonen
09-22-2012, 01:49 PM
See if this registry edit helps: http://forum.notebookreview.com/hardware-components-aftermarket-upgrades/587521-fix-realtek-sound-popping-high-pitched-tone-squeal.html#post7617517.

Hi mate, i'll try that fix when i have some time. Really thanks! I wonder why this setting is hidden under registry and no apparent option under HD Audio Manager or Sound applet of Control Panel? Any idea?

Here is my current settings. Enabled is already set to 1. Here is my screenshot:

11932

I found a strange statement in original post in the link you posted:

"Enabled - enables the power management. Default is 0. Set to 1 to disable and always prevent these noises."

...which seems WRONG, and "Enabled" key has to be set to 0 (zero) to disable which contradicts with the original poster's statement. Aren't i right?

The .reg file posted by original poster states "always disable" with "Enabled" key as zero which prooves the error:

https://www.asuswebstorage.com/navigate/s?u=pRgtlC

Thanks!

kimiraikkonen
09-24-2012, 09:02 AM
Is there a brief clarification related to my previous post, please? :) The registry keys are confusing in the link posted previously, on forum.notebookreview.com. "Enabled" key must be set to zero to disable these noises unlike the statement available on here (http://forum.notebookreview.com/hardware-components-aftermarket-upgrades/587521-fix-realtek-sound-popping-high-pitched-tone-squeal.html#post7617517), AFAIK:

"Enabled - enables the power management. Default is 0. Set to 1 to disable and always prevent these noises."

Thanks!

kimiraikkonen
10-02-2012, 07:39 PM
THANKS dstrakele. You've been very helpful and i set Delaytime to 10000 and OnlyBattery value to 1. All seems better than before. Thanks again!