View Full Version : Asus G55 Optical Drive Failiure

ROG Steve
09-23-2012, 01:57 PM
Hello I was wondering if anybody can help find out what's wrong with my optical drive. It wont read my discs, when I put one in it says no disc detected and it pops the drive open again because it thinks there isnt a disc installed. If anybody can help me that would be great because I really want to get Guild Wars 2 installed already before the weekend ends :/

09-23-2012, 02:14 PM
Are you certain you didn't disable the ODD in Power4Gear?

If so, try the UpperFilters/LowerFilters registry edit or cleaning the laser lenses.

ROG Steve
09-23-2012, 03:06 PM
ODD is enabled and the lense is cleaned all it is is that the optical drive doesnt think there is a disc inside when I put one in :/

09-23-2012, 04:51 PM
http://rog.asus.com/forum/showthread.php?12506-slimtype-bd-e-ds4e1s-WILL-NOT-READ-ANY-MEDIA&highlight=Black-bean offers some other things you can try, but you might also consider contacting your retailer to see if you can exchange your defective laptop for a new one.

ROG Steve
09-23-2012, 05:13 PM
I'd do it myself i have a laptop optical drive from my old laptop. The problem is it would void the warrenty if i did that so i might have to take it to bestbuy then :/

09-23-2012, 05:39 PM
Where did you read installing an ODD would void the Warranty?

ROG Steve
09-23-2012, 07:11 PM
Isnt opening the laptop and replacing a certain component voiding the warrenty? I mean if you opened up the keyboard to put an msata slot voids the warrenty.

09-23-2012, 08:35 PM
Not necessarily... You can put a new HDD or RAM chip in the laptop without voiding the Warranty. Installing a new ODD is a remove screw, pull out and unplug ODD, and replace procedure.

You can test your problematic ODD in another computer if you wish.

01-25-2013, 06:21 PM
Hi, after reading all the forums and fixes nothing worked. Removed drive, cleaned, deleted registry keys and upgraded the firmware.

Found the asus downlaods here: http://support.asus.com/download.aspx?SLanguage=en&m=G74Sx&p=3&s=336&os=30&hashedid=LUFmeP8fwFruEdH7

and under Utilities I downloaded and installed:

ATKACPI driver and hotkey-related utilities

KB Filter Driver

and my drive works flawlessly now. Not sure which one you need or if you need both but I hope this helps

Please let me know if it worked for you too.

01-28-2013, 07:03 AM
Check you HW.