View Full Version : [G74S] Audio Jack Issues

09-25-2012, 06:16 AM
Really hoping I can get some suggestions on what to do, because at this point I'm lost.

I've been having an issue for the past few months with my microphone jack not picking up my mic on my Razer Carcharias headset (Edit: I've also tested with 2 other mics and have confirmed the mics are all working on my desktop). At first it would just be a slight issue here and there where I'd be recording a video and notice my voice quality would drop in recordings or people on skype would mention I sounded weird. The port has always been a little loose and I wasn't 100% sure what the issue was until this past week. It's now gotten to the point that the only way the Realtek manager will even alert that a device has been plugged in is if I pull the pin at almost a 35 degree angle inside the jack; leading me to believe something has been knocked loose inside.

So I took it upon myself to try and solve my own issues instead of complaining about the laptop itself and then trying to have it repaired; especially after reading some of these horror stories regarding the service. Anyway, hoping that could be avoided and purchased a Steelseries Siberia USB Soundcard, figuring it would be a good solution to the bad audio port and also a decent way to get a little more sound quality (which at least the quality was an improvement). However, this "solution" last about 30 seconds as I sang joyfully into my mic with playback enabled on the mic in sound properties. Unfortunately the victory was cut short as I heard a weird screech followed by the mic no longer being picked up. I spent around 2-3 hours uninstalling and re-installing both the usb soundcard and the real-tek drivers and testing on every single usb port on my G74. Eventually I noticed whenever the usb soundcard moved I got a weird feedback from having listen enabled and I eventually noticed it was providing audio in skype without it actually showing up as sound (the green volume bars) in properties. Unfortunately this was also short lived and now I can't get a lick of response from it.

I'm really not sure where to go from where and hoping someone can provide some insight, suggestions, or at least convince me my laptop will come back from repairs within a reasonable time-frame and not 10 times worse then it was when I sent it out.

Also if it's any help while researching the issue I read someone suggesting the built in microphone was taking priority over any new devices and not allowing them to be detected, so as I said I tried both disabling the built in mic and just completely disabling the real-tek drivers but had no luck.

Thanks in advance.

09-25-2012, 09:15 AM
It sounds like your microphone jack is bad. http://forum.notebookreview.com/asus-reviews-owners-lounges/427556-g51j-a1-owners-lounge-34.html#post5879478 shows how an audio jack works.

Does the USB sound card work on another computer?

09-25-2012, 09:28 PM
Ya, I'm pretty positive the audio jack has been bumped out of position. I have tested the usb sound card on my desk top with the exact same headset and it works flawlessly, so I'm still not sure why that isn't working. Might be worth adding when moving my connector into the jack at that 45 degree angle I only get a detection through the Real-Tek message. The microphone does not show up under recording devices in sound properties.