PDA

View Full Version : G73jh Touchpad Issue - Flashed BIOS and updated drivers didn't help



Delete
09-26-2012, 03:49 AM
Hi. I've had my G73 for eight months and recently had an issue start with a pop message "touchpad has been disabled because the Synatics driver has detected another device plugged in". It's the same message I get when I plug in the mouse, but it pops up constantly, sometimes 3-4 times in a row, and I lose control of the mouse.

I read through some old forum posts about touchpad issues and applied some of the suggestions like flashing the BIOS with latest drivers and updating the synaptic touchpad drivers. Didn't help.

I disabled the touchpad using fn f9. Didn't help.

I've heard there is an issue with tape on the bottom of the touchpad that accumulates a static charge. Before taking apart my 'puter I came here to ask if other people are having this issue, and what to do about it.

Thank you for your help.

dstrakele
09-26-2012, 05:52 AM
You wrote the issue has occurred jusdoe t recently. If you use Windows System Restore to restore your system to a time before the issue first occurre, does it stop?

If not, does disabling the touchpad in the BIOS stop the popup messages?

Delete
09-26-2012, 06:04 AM
You wrote the issue has occurred jusdoe t recently. If you use Windows System Restore to restore your system to a time before the issue first occurre, does it stop?

If not, does disabling the touchpad in the BIOS stop the popup messages?

Oddly enough I discovered that sys restore was disabled, so I created a restore point before flashing the BIOS today. I tried disabling the touchpad in the BIOS and while I could see the option, it was greyed out (couldn't be highlighted). I tried disabling the driver two different ways and neither worked. It's really frustrating. I just had six synaptic messages in a row, lost control of my mouse for about 15 seconds.