View Full Version : Touchpad on G73 has gone haywire after 8 months

09-26-2012, 06:14 PM
Hi, I've owned a G73jh for about eight months. Recently I started getting synaptic touchpad messages and it has turned into a plague. The message pops up when I plug in a USB mouse "driver has detected another device plugged into your computer." Now imagine that message popping up 100 times per hour, interrupting your control of the mouse. Now imagine that you're playing a FPS game and suddenly you can't aim or fire. Yeah. It sucks.

So I've tried updating the drivers, flashing the BIOS, and disabling the touchpad. I can't disable it in BIOS -- the option shows on the BIOS screen but can't be highlighted -- and disabling it using Fn F9 doesn't get rid of the pop up messages. Nothing has worked. In fact, the problem appears to be getting worse. About once every five minutes I get up to six messages in a row. Each time my g73 controls freeze for about 15 seconds.

Also, I've tried going back to a restore point, but discovered that the factory settings for this beast are F--ked up. Security was completely disabled. Restore points were turned off. The camera takes random pictures of me (I covered it with tape). The computer turns on in the middle of the night doing God knows what.

Anyway, if anyone knows how to get rid of the pop up messages, I'd appreciate hearing from you.

09-27-2012, 12:56 AM
Well, maybe not as immediate a solution as you're looking for, but I'd say that sounds like the cable for the trackpad is going bad. So replacing that would probably resolve the issue, it just might require sending it in for service.

09-27-2012, 04:52 AM
I had a feeling it might be hardware related, not software. I was hoping an asus expert would know. I wrote to chastity, the touchpad expert, and haven't heard back yet. Thanks for the advice.