PDA

View Full Version : Speakers and subwoofer G75



Sinless
10-07-2012, 08:29 PM
Noob question, are the speakers and subwoofer integrated on the motherboard??

I'm asking because i recived my G75 from RMA the last friday, but the speakers/subwoofer are not working as they would. Maybe the guys from the service center did not properly plugged the wires? or i will need a replacement mobo???.

bignazpwns
10-07-2012, 08:57 PM
There all connected with plugs.

No sound at all? Volume up? Under playback devices is VIA high deff audio chosen?

Sinless
10-07-2012, 10:10 PM
I'm using the latest VIA drivers provided from Asus drivers page.

Every 1-2 seconds i can hear a weird sound, like static noise coming from the subwoofer. When i uninstall the VIA driver and use the Microsoft generic audio drivers, that annoying noise is gone, but the sound quality sux. I hope the subwoofer cable is not plugged properly. Also my backlight keyboard is not turning on. This two issues are since when i received my g75 from RMA. I will send my G75 for repairs again tomorrow.

bignazpwns
10-07-2012, 10:26 PM
You got the ATKACPI driver install? Do the other FN keys work such as turning the wifi on and off? If so then they forgot to connect the backlight cable and if they dident do that then they might of done the same with your speakers.

Send it in for one thing get it back with another problem. Its always fun when you spend more time shipping the thing back then using it.

Sinless
10-07-2012, 10:47 PM
Yes, i reinstalled ATKACPI many times, all FN keys works (screen brightness, disable touchpad etc), but backlight keyborad is not working. I waited for almost 2 months to have my G75 back, and now this :(.

bignazpwns
10-07-2012, 11:10 PM
Yeah they dident connect the cabled for your backlight. Its a pretty easy fix but you cant do it without voiding the warranty. When you send it back tell them you want it fully tested prior so having it sent back.

c_man
10-08-2012, 10:25 AM
Yes, i reinstalled ATKACPI many times, all FN keys works (screen brightness, disable touchpad etc), but backlight keyborad is not working. I waited for almost 2 months to have my G75 back, and now this :(.

There is like 99% chance it's disabled from BIOS and only in service you can fix this. I had 2 like this, it's a 1min. fix if you can get to a service in your area that can work with Asus.