PDA

View Full Version : G74SX - Unable to connect in wired.



JamesNgkk
10-09-2012, 08:17 AM
Fellow RoGers,

I kindly seek help from anyone to help me with my problem. My laptop could not connect to the internet in wired mode. Only able to achieve connection in wireless mode. What happened was my brother used some driver update software and installed various driver updates on my laptop. However after the updates, i discovered my laptop could not connect via wired mode anymore. Can someone help me to rectify this problem or at least point me in a right direction?

In my device manager i see Realtek PCIe GBE Family Controller under the Network Adaptors. I would suppose this to be my ethernet controller (please correct me if i am wrong). It is stated as working properly and is enabled. However nothing happens when i plug my ethernet cable in. I have tried removing the device and re-installing it. I have tried going to the asus website and downloaded the drivers for it and after installation, still not working. I have exhausted whatever little knowledge that i have to fix this issue. Can someone help me out?

dstrakele
10-09-2012, 08:52 PM
Give details as to how you performed the Realtek Ethernet driver installation.

What Realtek driver version are you currently running?

Post a screenshot of the "Driver File Details" dialog from the "Properties-Driver tab-Driver Details" of the Realtek PCIe GBE Family Controller in Device Manager.

Do you have Cable or DSL Internet?

Launch "Control Panel - Network and Internet - Network Connections". Does "Local Area Connection" display a red "X"? If so, right-click on it and choose "Diagnose" from the popup menu. What does it tell you?

JamesNgkk
10-10-2012, 01:37 PM
Thanks dstrakele for your input. I have bought a new ethernet cable out of desperation hoping it was the cable that is broken and nothing to do with my laptop. Since installation of the brand new cable, i have got connection back. From the looks of it, it SEEMS to be the cable that is the problem. *cross fingers. I will carry on observing and see if the connection breaks again.