View Full Version : I can't install well Nvidia 306.97 newest driver... such as Physx software driver..

10-10-2012, 11:27 PM
I can't install well Nvidia 306.97 newest driver... such as Physx software driver..

Does anyone have problem like me?? or is this only my problem??

I m using 670m G75vw ds73...

I could install gp driver 3d controller driver but I can't install nvidia update and physx software driver...

the message show me failed ....

any help will appreciate...

10-10-2012, 11:45 PM
you probably downloaded the desktop version of the driver rather than the M version

here is the correct download link:

Download meh now! (http://us.download.nvidia.com/Windows/306.97/306.97-notebook-win8-win7-winvista-64bit-international-whql.exe)

10-10-2012, 11:59 PM
Did you do a clean uninstall to remove physx/video card drivers completely first. video card drivers can be a real PITA sometimes.

Use something like Driver Fusion or DriverSweeper (in windows safe mode.. not normal windows) to clear out all your old drivers first.
Then reboot into normal windows and try fresh install. (I also usually follow this process up with a registry orphan cleaning app before driver install to remove any remaining keys pointing to driver bits.... then after registry cleaning I will do the new driver install)

Using nvidia "clean install" option under advanced does work... but not 100% of the time... the method above is the fail safe 99.9% of the time for all drivers... However, there are rare instances when a driver gets corrupted during original install and gives issues.

If that doesn't work there is another problem with your video card driver I had already happen once on this G75 laptop already. I had to retro-install an old version of physx to fix the problem before it would uninstall...apparently the old version got botched mid way through install (and I never knew it, even though it worked in games...it was a corrupt install) due to this it never uninstalled or reinstalled new versions properly (even using all the classic super secret ninja moves above that have worked for me for the last 10 years+).

The solution was get latest version of nvidia driver... then when it gets to point of install it was asking for some weird file....I had to find just the physx driver executable it wanted (same version that was corrupt) and point to the old executable during the new install... it then finished fixing the old install and I was able to update. Then after that I was able to finish the newest version of physx install driver overtop of it. Royale pain..

To know if this second thing is your problem does it ask where a file is located during install/uninistall of new physx driver? If it does you may have same sketchy issue I did... but it's easy to solve.

10-11-2012, 03:03 PM
Thanks for response I appreciate. I will try this.

10-11-2012, 03:13 PM
Get the mobile version of the driver for your 670M. And when installing click the clean install button.

Also i highly highly reccomend that you install this as a custom installation and uncheck the Nvidia Update and PhysX buttons so that they do not get installed.

Nvidia Update is basically bloatware.
And the PhysX in the 306.97 driver is an older version for some reason :s So you should then just download PhysX from the Nvidia site on its own and install.. Then Enjoy :)

10-11-2012, 08:15 PM
I tried what you suggested mrwolf, didnt work. When I install the new driver, only the driver installs, and everything else fails. Tried everything you guys posted here and nothing works. No idea whats going on. Used the old drivers and they installed fine.

10-12-2012, 03:35 PM
@Montavious, normally what Woots and mrwolf suggested are sufficient to upgrade nvidia drivers and software.

maybe you can try uninstall everything related to nvidia from control panel, reboot into safe mode to install the new nvidia packages.

10-13-2012, 07:38 AM
Bought my G55 today and had a similar problem. Newest drivers installed but Physx failed to install. I uninstalled Physx from Programs, rebooted, reinstalled newest drivers again with no problems.

I read of this problem on another site. Some sort of issue with the current Physx installation not installing correctly.

10-13-2012, 08:29 AM
I installed the newest drivers on my G55 and I had no problem, but after all I am using Windows 8, and this could be a factor.

10-13-2012, 08:40 AM
I can also confirm that the new drivers are working for me.