PDA

View Full Version : G75VW & Atheros Gigabit controller speed problem [solved]



MUPiSz
10-14-2012, 10:01 PM
both of my G75vw's list having the Atheros AR8151 PCI-e gigabit controller.

problem is it list top speed choice as 100Mbps duplex. home net is gigabit.

for testing, i tried a few brand new Cat5 & Cat6 cables connecting from notebook to netgear gigabit switch, still 100Mbps.

gotta ask, how does one get these nic to do 1000Mbps ?

MUPiSz
10-14-2012, 10:50 PM
gee, nevermind, i updated the Atheros drivers from Qualcomm/Atheros site. now i get gigabit connections on both G75vw's. go figure.


url: http://www.atheros.com/download.php?type=driver&id=49
driver: 2.1.0.12
date: 09.21.2012
provider: Qualcomm Atheros

g75owner
10-29-2012, 10:53 PM
I have the G75VW-DS73-3D. Has anyone seen this problem please?
The Atheros AR8151 PCI-E Gigabit Ethernet Port has a major UPLOAD SPEED problem!

The upload speed is capped at a mere 0.1 MB /SEC, it should 100 times faster 10 MB / Sec!!! Note 1, the download speed is perfect! Note 2, the Wi-Fi upload & download speeds are perfect! Note 3, its not a unique fault with my G75 as a 2nd working G75 has same problem! Slow uploads are apparent when uploading data to the network, such as running an UPLOAD INTERNET SPEED-TEST, or COPYING A FILE to the network. Its also apparent copying files to a NAS storage driver or a 2nd directly connected PC. Because of Note 3 I want Asus to replicate this problem and troubleshoot it. I don't want to RMA!

Here's what I've tried.

#1. Updated Driver but Asus site only had V2.0.8.8. Found post with Qualcomm V2.1.0.12. Same problem!
#2. Used several new LAN cables. Same problem. Slow Upload! 0.1 MB / sec
#3. Virus checked the G75. No viruses found! Slow Upload! 0.1 MB / sec
#4. Turned off the virus-checker / firewall. No difference! Slow Upload! 0.1 MB / sec
#5. Selected high-performance Power mode. Still Slow Upload! 0.1 MB / sec
#6. Tested using a 2nd identical working G75. Same slow upload problem! 0.1 MB / sec
#7. Tested network using a HP laptop running Windows 7. Its works fast! Upload speed: 10 MB / sec
#8. Tested network using an Asus EEEPC running XP. Its works fast! Upload speed: 10 Mb / Sec!
#9. Tested using a NAS storage drive directly connected to the G75. Slow Upload: 0.1 MB / sec.
#10. Tested connecting the G75 directly to 2nd G75 or the HP. Slow Upload! 0.1 MB / sec
#11. Ran a G75 Wi-Fi versus Ethernet cable test. Wi-fi copies at 2-3 MB / Sec as expected.
#12. Substituted the Router a UBEE, for a Cisco. Same slow upload problem: 0.1 MB / sec
#13. Tried changing TCP Tuning Settings. Same slow upload problem! 0.1 MB / sec
#14. Altered Atheros Device Manager settings i.e. Speed and Duplex. No difference! 0.1 MB / sec.
#15. Searched internet for known Atheros Upload speed problems. Nothing found that fixes the problem!

I have tried many times unsuccessfully to get an answer to this problem and that's unacceptable.
Asus US OUTSOURCED support is so poor, their favorite phrase is "for a try"!!!!!!

dstrakele
10-30-2012, 01:09 AM
It looks like the version 2.1.0.12 Ethernet driver update worked for @MUPiSz. Maybe he installed it differently. What are the exact steps you performed for your driver update?

tkolarik
10-30-2012, 02:58 AM
Maybe you could give more specific info, like make and model of your router, any other switches or routers, what is the rated sped of your network storage. How are you communicating your two computers via NIC to router. And your cables, just cause their new doesn't mean they are cat5e or cat 6. Also, are you reading the Mb megabits or MB? There is an 8X difference.

I just finished a router upgrade, looks like I didn't have to because my DirecTV Ethernet connecting was messing up the LAN portion of my network.

g75owner
10-30-2012, 06:46 AM
EDIT:
PLEASE DISREGARD
. I think I've made some progress....

The router is locked down by the ISP but I fear I've overcomplicated this posting so can we simplify it because we're getting away from the real problem I fear... Imagine my home network has no router, just 4 isolated computers and a WD-NAS...

#1. New G75,
#2. Old G75,
#3. HP (Win7),
#4. EEEPC (XP),
#5. WD NAS 'My Book Live'!

Imagine I only ever connect the WD NAS to each machine individually and directly using two different LAN cables, and run two tests copying from and then to the WD NAS. I'm finding the cables are making no difference to the speeds, these are the actual speeds that I get :-

New G75 + WD-NAS -> Download 10 MB / Sec - Upload 0.1 MB / Sec
Old G75 + WD-NAS -> Download 10 MB / Sec - Upload 0.1 MB / Sec
HP +WD NAS -> Download 10 MB / Sec - Upload 10 MB / Sec
EEEPC + WD NAS -> Download 10 MB / Sec - Upload 10 MB / Sec

I'm quoting from the Win7 copy screen which lists about 50-100 KB for both of the G75's upload speeds, whereas the HP and EEEPC are uploading at 10 MB / Sec. The copy dialog is clear no mixing-up of the units!

Regarding patching the Atheros. The installer options are quite fixed. I just did a REPAIR the first time then did a test, then a modify the second time to be sure it had installed. The driver says its updated. But remember the New G75 still has the older driver, but both machines still exhibit the slow upload speed problem when compared to the HP and EEEPC!

MUPiSz
11-01-2012, 01:47 AM
@g75owner,

i too have the WD MBL and two G75's here at home and a NAS. and copying *anything/anysize* from/to either G75 was futile to say the least.

however, copying files from one of my linux VM guests that is on a windows server to another windows server was quite fast. same with VM guests on a NAS run from ESXi.

so i knew the nic's on those machines and that the switch was not at fault. i changed cables anyways just to be sure.

for me, it came down to the G75's which are running Win 7 x64. frustrating since they are basically new. looks like you have narrowed it down along those same lines yourself.

researching on internet i found many Win7 users were having this very slow network speed and there are many suggestions of what to tweak in Win 7 to correct it. none of those Win7 tweaks worked for my G75's. some of the tweaks are probably worth looking into.

http://www.sevenforums.com/network-sharing/74556-enable-disable-tcp-auto-tuning.html


i uninstalled the old Atheros drivers and installed the updated Qualcomm version.
under device manager for network adapters, the name reads, "Qualcomm Atheros AR8151 PCI-E Gigabit Ethernet Controller (NDIS 6.20)"

at present that is all i can offer towards helping. i know first hand how frustrating this particular issue is. when you get it working, post it here. will save others from having to go through this really frustrating issue.

rewben
11-01-2012, 02:38 AM
@MUPiSz, please check out here for a possible solution (http://forum.avast.com/index.php?topic=88532.15) for you. it seemed that @g75owner has the solution to his issue (http://rog.asus.com/forum/showthread.php?24630-Two-G75-s-with-the-same-Atheros-AR8151-major-UPLOAD-SPEED-problem-Qualcomm-V2.1.0.12&p=177019&viewfull=1#post177019) but maybe he will put down the exact steps.

MUPiSz
11-01-2012, 06:14 PM
@MUPiSz, please check out here for a possible solution (http://forum.avast.com/index.php?topic=88532.15) for you. it seemed that @g75owner has the solution to his issue (http://rog.asus.com/forum/showthread.php?24630-Two-G75-s-with-the-same-Atheros-AR8151-major-UPLOAD-SPEED-problem-Qualcomm-V2.1.0.12&p=177019&viewfull=1#post177019) but maybe he will put down the exact steps.

yeah, that's a good link. i'll keep it about for reference.

upgrading the drivers did the trick for my two machines

thx

rewben
11-02-2012, 01:29 AM
ah.. i didn't see that you had the issue resolved lol!

Sereby
04-10-2014, 08:02 PM
@MUPiSz, please check out here for a possible solution (http://forum.avast.com/index.php?topic=88532.15) for you. it seemed that @g75owner has the solution to his issue (http://rog.asus.com/forum/showthread.php?24630-Two-G75-s-with-the-same-Atheros-AR8151-major-UPLOAD-SPEED-problem-Qualcomm-V2.1.0.12&p=177019&viewfull=1#post177019) but maybe he will put down the exact steps.

Thanks, rewben! This solved it for me.

Quoted from your link:


One more thing that makes a significant difference is to go to Device Manager and open the propoerties for the Network Adapter, click the Advanced tab and disable Large Send Offload (IPv4) and enable Large Send Offload v2 (IPv4). You can also try changing the Flow control from RX & TX to disabled and check, if no difference re-enable (because it is the default) and also try disabling the Interrupt Moderation and testing.

The only steps I needed to take were:

1) disable Large Send Offload (IPv4)
2) enable Large Send Offload v2 (IPv4)
3) change the Flow control from RX & TX to disabled