PDA

View Full Version : RMA Status through ASUS



Zjoseph
10-16-2012, 02:58 PM
So i recently had an issue where when i turned on my notebook i recieved a solid black screen with a blinking cursor, I immediately called asus and since im in the warranty period they set up an RMA for me. I sent it out to the Milpitas repair center last friday. Ive been trying to check my RMA online but i get an error and it says it cannot be found. Im gettin nervous that il see it again and iwas wondering if anyone knows if i should contact the service center to check and if so, who do i call to reach the Milpitas repair center? :(

c_man
10-16-2012, 03:17 PM
Well, so far reports about Asus RMA are not great. It might take a while. You should have some phone number on your papers. Give them a call and ask.

chrsplmr
10-16-2012, 03:20 PM
Welcome to ROG Zjoseph ..

PM cl-scott with your rma numbers and all your information..
he can, when he gets a speck of time, check things are moving along for you..
Dont panic .. the waiting is the worst part.

Thank you for your patience and respect here .. please keep us 'posted' as
to your progress and outcome ..
We are as concerned about this working out for you as you are .. this time and every time.c.


c_man .. no offense .. but let me point out again .. (for those playing along at home)
that 'the reports' are of those with issue .. we rarely if ever see the flawless executions.
Never having to say this would be great though eh ??? Not yet. alas.

Zjoseph
10-16-2012, 04:01 PM
Thanks i appreciate the warm words, So far it has felt like a lifetime without my notebook and it has only been a little over a week! Hopefully things turn out, so far this forum has been very helpful! Thanks!
~Zach~

c_man
10-16-2012, 04:06 PM
I always put in the good stuff. For example great service guys, but it takes ages for the parts to arrive. I've been there.

Zjoseph
10-16-2012, 04:14 PM
Well im hoping its just a hard-drive replacement which isn't too bad for its a fairly common part. Luckily my warranty runs out in 2 months! Im glad this happened when it did personally!

chrsplmr
10-16-2012, 04:16 PM
cMan..I know .. didnt mean to suggest anything less my friend.

Zjoe ... hahha .. yes, lucky.
we are hope'n.c.

c_man
10-16-2012, 04:18 PM
No problem. Guys in service said it's not that uncommon. I'm glad they fixed it in the end.

Zjoseph
10-16-2012, 04:22 PM
Yep, at this point its just a waiting game. Il have to give them a call later this afternoon and ask. Im very curious as to what the problem is for ive seen some posts online by searching google rgarding the same thing but no answers as to what it is!

Zjoseph
10-18-2012, 07:05 PM
Got my machine back today and is already in beautiful working order, Thanks ASUS!!!!

TehJorge
10-18-2012, 08:22 PM
I've sent mine in before and checked my RMA status for 2 weeks straight with no update what so ever. When it finally got back to my house I checked again and it said "Waiting for parts" lol I'd just give them a call to see whats up. That's what i did :)

chrsplmr
10-18-2012, 09:21 PM
A few days before the 16th you RMA'd and posted above. Today on the 18th RMA Complete, all is well ???
TouchDown Support !!!
This is great news !!! Thank you for reporting this.

Cudos where it is due.

Hope you have a blast with that bad boy .. hahhaa
that's why you bought it right ?? Enjoy.

Time to get your ROGon .. ya'll come back now, ya here.

TehJorge .. And your RMA worked out as well ?? just took a few weeks ?? awesome.c.

Zjoseph
10-29-2012, 07:49 PM
Got my machine back today and is already in beautiful working order, Thanks ASUS!!!!

Also want to throw a shotout to cl-scott, really does a great job and is extremely helpful! If anyone has any questions regarding their RMA feel free to PM him, he will be more than happy to help when he gets some free time! Thanks Scott!!