View Full Version : G75VW-BBK Atheros 8151 problem

10-18-2012, 02:13 AM
I was using my G75VW the other night and got a bluescreen related to NDIS.SYS. First time I've ended up with a BSoD in Win 7, so I guess it's a special occasion. Anyway, now my Gigabit LAN card won't connect to my network, getting a 169.X.X.X address while on DHCP. It also does not connect when I put in a correct Static IP for the network, listing it as "Unidentified Network" under the Network and Sharing Center.

I've tried removing the device, reinstalling, updating drivers, disabling, re-enabling, and I still have no connectivity on the LAN port.
Wireless still works, but, well, Wireless isn't Gigabit speeds.

Anyone else run into this, and any suggestions?

10-18-2012, 02:20 AM
can you find and try this latest driver (http://www.qca.qualcomm.com/corporate/content.php?nav1=146)? i am using that one.

however, i should tell you that i had no issue regarding the network (wired or wireless), even with the latest drivers from asus.

10-18-2012, 02:28 AM
I am currently using those same drivers, yes. I thought that updating the drivers might help fix the problem, but it seems to persist.
I have had the laptop for nearly 4 months now, and this is the first issue I've had with the LAN drivers, so it's not a recurring thing.

10-18-2012, 02:48 AM
yes, it's weird. are you running stock windows? and do you happen to run mcAfee?

10-18-2012, 02:53 AM
Where's the fella who normally recommends runnin' "sfc /scannow" on most of the threads? I guess I'll be that guy this time... Type "sfc /scannow" in an elevated cmd prompt. You could also try rebooting the router.

10-18-2012, 02:53 AM
Yeah, just the same install of Windows 7 Home Premium 64-bit that came with the machine.

And no, I use Microsoft Security Essentials for AV/AM.

10-18-2012, 03:01 AM
@AzraelsKiss, haha ok!

@FoxKelfonne, if that command didn't fix your issue, i would suggest you try to uninstall, reboot and reinstall the driver in safe mode.

10-18-2012, 03:23 AM
Yeah, no dice. It did not find any file integrity violations.
I can't reboot the network router at the moment, but that will be the next thing I try, I suppose.

10-18-2012, 12:19 PM
Where's the fella who normally recommends runnin' "sfc /scannow" on most of the threads? I guess I'll be that guy this time... Type "sfc /scannow" in an elevated cmd prompt. You could also try rebooting the router.

HAHAHA that would be ME!

10-18-2012, 12:21 PM
Fox! Did you originally have another AV software? Removing McAfee and Norton and some others can cause issues unless you use removal tools, even if it was just the bloatware that came pre-installed on it. if that's not the case, there are some other ways to diagnose this, though TBH if it takes much more effort you might be better off backing up and restoring to factory settings.

10-29-2012, 10:50 PM
I have the G75VW-DS73-3D. Has anyone seen this problem please?
The Atheros AR8151 PCI-E Gigabit Ethernet Port has a major UPLOAD SPEED problem!

The upload speed is capped at a mere 0.1 MB /SEC, it should 100 times faster 10 MB / Sec!!! Note 1, the download speed is perfect! Note 2, the Wi-Fi upload & download speeds are perfect! Note 3, its not a unique fault with my G75 as a 2nd working G75 has same problem! Slow uploads are apparent when uploading data to the network, such as running an UPLOAD INTERNET SPEED-TEST, or COPYING A FILE to the network. Its also apparent copying files to a NAS storage driver or a 2nd directly connected PC. Because of Note 3 I want Asus to replicate this problem and troubleshoot it. I don't want to RMA!

Here's what I've tried.

#1. Updated Driver but Asus site only had V2.0.8.8. Found post with Qualcomm V2.1.0.12. Same problem!
#2. Used several new LAN cables. Same problem. Slow Upload! 0.1 MB / sec
#3. Virus checked the G75. No viruses found! Slow Upload! 0.1 MB / sec
#4. Turned off the virus-checker / firewall. No difference! Slow Upload! 0.1 MB / sec
#5. Selected high-performance Power mode. Still Slow Upload! 0.1 MB / sec
#6. Tested using a 2nd identical working G75. Same slow upload problem! 0.1 MB / sec
#7. Tested network using a HP laptop running Windows 7. Its works fast! Upload speed: 10 MB / sec
#8. Tested network using an Asus EEEPC running XP. Its works fast! Upload speed: 10 Mb / Sec!
#9. Tested using a NAS storage drive directly connected to the G75. Slow Upload: 0.1 MB / sec.
#10. Tested connecting the G75 directly to 2nd G75 or the HP. Slow Upload! 0.1 MB / sec
#11. Ran a G75 Wi-Fi versus Ethernet cable test. Wi-fi copies at 2-3 MB / Sec as expected.
#12. Substituted the Router a UBEE, for a Cisco. Same slow upload problem: 0.1 MB / sec
#13. Tried changing TCP Tuning Settings. Same slow upload problem! 0.1 MB / sec
#14. Altered Atheros Device Manager settings i.e. Speed and Duplex. No difference! 0.1 MB / sec.
#15. Searched internet for known Atheros Upload speed problems. Nothing found that fixes the problem!

I have tried many times unsuccessfully to get an answer to this problem and that's unacceptable.
Asus US OUTSOURCED support is so poor, their favorite phrase is "for a try"!!!!!!

10-30-2012, 03:10 AM
Hard to understand how your router assigns a good IP address to the wifi card but not to the NIC? I'd remove all those manual settings and in a cmd.exe window type ipconfig /release then ipconfig /renew and followed by ipconfig /all . If you the first three parts are not the same, you might have some router settings off.

10-30-2012, 06:31 AM
. I think I've made some progress....

My ISP locks down the UBEE Rotuer, but that's not the problem because If I cannect a WD NAS net drive directly using a LAN cable (and no router), it exhibits the same problem. Also, the old G75 is tweaked, but the new G75 is untouched, but both exhibit the upload throttling to a hundreth of normal speed. If I try another computer a HP with Win7, and connect it directly to either of the G75's using a LAN cable, I have the same problem. So its not the router, and its not the WD NAS!. Its not the LAN cables either, because if I connect the WD NAS to an EEEPC running XP, or to the HP running Win 7, the up copy speed is 10 MB / Sec. This problem is fundamentally down to somethig common to the G75's! Is no one else seeing this problem?

The router is locked down by the ISP but I fear I've overcomplicated this posting so can we simplify it because we're getting away from the real problem I fear... Imagine my home network has no router, just 4 isolated computers and a WD-NAS...

#1. New G75,
#2. Old G75,
#3. HP (Win7),
#4. EEEPC (XP),
#5. WD NAS 'My Book Live'!

Imagine I only ever connect the WD NAS to each machine individually and directly using two different LAN cables, and run two tests copying from and then to the WD NAS. I'm finding the cables are making no difference to the speeds, these are the actual speeds that I get :-

New G75 + WD-NAS -> Download 10 MB / Sec - Upload 0.1 MB / Sec
Old G75 + WD-NAS -> Download 10 MB / Sec - Upload 0.1 MB / Sec
HP +WD NAS -> Download 10 MB / Sec - Upload 10 MB / Sec
EEEPC + WD NAS -> Download 10 MB / Sec - Upload 10 MB / Sec

I'm quoting from the Win7 copy screen which lists about 50-100 KB for both of the G75's upload speeds, whereas the HP and EEEPC are uploading at 10 MB / Sec. The copy dialog is clear no mixing-up of the units!

Regarding patching the Atheros. The installer options are quite fixed. I just did a REPAIR the first time then did a test, then a modify the second time to be sure it had installed. The driver says its updated. But remember the New G75 still has the older driver, but both machines still exhibit the slow upload speed problem when compared to the HP and EEEPC!