PDA

View Full Version : Stutter/clicking in Media Player about 20 seconds before the end of each track



Vardion
10-20-2012, 07:51 AM
Hi,

since I replaced my old X-Fi with a Phoebus, I've got the following problem: when I play multiple audio tracks in Media Player 12 (e.g. right-click a directory and have Media Player play all tracks within it) I get some stutter or clicking about 20 seconds before the end of each track.
The same problem is described (for different soundcards) here (http://answers.microsoft.com/en-us/windows/forum/windows_7-sound/music-stutters-in-last-20-seconds-on-windows-media/4e44dea3-c04c-4f84-b193-2b0a1420afb1) and here (http://forums.anandtech.com/showthread.php?t=2025638). Conclusion in both cases seems to be a faulty driver.
I'm currently using the 7.0.1.20 beta driver for Win7/64. Anyone else got this problem or a solution?

Regards,
Vardion

cx-ray
10-20-2012, 09:27 AM
Yeah, I had the same problem. It appears to be isolated to Media Player as far as my testing went.

I mainly play music over my network from a NAS. So, I began to trouble shoot the issue from the perspective of my network. As you probably have found out by now the stutter isn't always consistent or easy to reproduce. You have to just let the music play for a while. To make a long story short I didn't find a fix (other than using a different music player) when I actively troubleshooted it.

Then, by shear coincidence I managed to fix it when I was testing for an unrelated matter. After I disabled Large Send Offload V2 in my network adapter settings, the stuttering stopped. Even when I play music from my internal drive there's no stuttering. This leads me to think that there's probably more going on then just a sound driver problem. It looks like an interaction of multiple components that's causing it. (I'm using Intel 17.3 network drivers on a RIVE mobo).