PDA

View Full Version : G2SG-A1 - Power issues



LeviathanPT
10-22-2012, 05:33 PM
Hi there,

I know that what i am about to say may not have any solution besides "set it on fire" or "throw it against a wall" but for my friends sake i will request some help since it may be more common than expected.

My friends purchased a Asus G2SG-A1 a long time ago (warranty is gone) and what's happening is that from time to time (randomly) the computer simply stops working, no lights, no activity, no sound. Then it takes a week or a month without anything plugged and suddently it comes back to life, with no apparent reason.

I had the computer the past month @ my house working to see if i could figure what the hell was wrong with it, all went fine until today it just wouldnt power up. I checked the AC adaptor and its fine, voltage is getting to the tip and the issue must be internal.

Any of you ever experienced such weird symptom ?

Im currently split between_
- a issue caused by some component having dificulties in starting on cold temperatures. (its very cold here)
- Faulty component, CPU/HDD but it seems weird since it should give an error or at least a signal of power being received and it simply doesnt.

Battery isnt the one to blame since it happens in every way possible.

Any suggestions or comments would be appreciated!

Thanks

PS: Made a poll just in case i need to bring the bad news to my friend and how i will do it

dstrakele
10-22-2012, 06:52 PM
When you say the laptop simply stops working, do you mean it shuts down like someone pulled the plug or does it refuse to start again after being shut down normally?

LeviathanPT
10-22-2012, 06:55 PM
It refuses to start again after being shut normally. He worked for a whole month without any problems, today i tried to start it up and it was dead.

Also theres a high chance that if i place it in the trunk of a car and go have a ride with it that when it comes back it is working again.
My friend said he once tried to shake it like if it was some kind of shaker just to see if it got back on working :p .

cl-scott
10-22-2012, 07:35 PM
Sounds like a good candidate for the old bad caps issue.

http://www.badcaps.net/pages.php?vid=5

So if you're a good hand with a soldering iron, it can be a cheap and easy fix in a lot of cases. If not, you can end up making the problem even worse.

LeviathanPT
10-22-2012, 07:37 PM
As much as i am tempted to believe it is related, none of those symptoms actually match the one in here. Theres no lights activity when connecting this directly to the power outlet.

LeviathanPT
10-22-2012, 08:50 PM
Just revived! I kept pressing power button over and over while inserting the power cable and it started ! :s

This laptop is cursed.