View Full Version : Thank God for Amex!

05-25-2011, 03:14 AM
So I got my new G73S from newegg today.
SO in Ubuntu, keyboad lights don't work - I see they dont work well in windows either.
FN Keys dont work well in ubuntu - I see they don't work well in windows either.
Touchpad is wierd in Ubuntu - I can scroll and move the mouse (no two finger scroll) but I have no tapping - I see there are touchpad problems in windows too. Removing tape!!?? Whatever dude.

The short story is I am packing it up and returning to newegg. If they won't take it, I'll charge it back on my Amex. Use Amex to buy stuff like this. Then you aren't stuck with a less than functional device for your (these days) hard earned cache.

It's a shame too. I was hoping the "New Revision Certified Design" sticker on my Asus G73S would have actually meant something.

05-26-2011, 12:45 PM
Did a fresh install of Natty and now I can tap with the mouse.
Keyboard LED still no workie.
Screen Brightness FN keys now no workie.
USB read spped is like 8 MB/S copying my data back.
Odd thing is that it was 17 MB/S writing the data to the USB drive when I moved the data in the first place for the fresh install.
Same HDD drive, same USB port, same USB drive.

I was going to give it a chance with the fresh install, but man, this thing does not fail to disappoint.
I got rid of my HP DV7 due to sandy bridge, but jeez, at least everything worked on the HP, FN keys webcam etc.
Speaking of webcams, this thing is like slow-mo. Whats the deal with that?
Really Asus should be paying Chastity for all the support, which is much more convenient than the Asus support!

Any recommendations on a replacement?

05-26-2011, 01:17 PM
USB 3 - No Workie.
Sweet! I plug my USB 3 WD Terrabyte portable drive into the USB 3 port and .....


Plug it into a USB 2 port and it works.

Asus Must Hate Linux and Vicariously,,, ME

05-26-2011, 03:45 PM
Do you know for sure that you have a driver installed for the USB 3 controller?

05-26-2011, 04:44 PM
Thanks for the response xeromist.

Fortunately, Linux started supporting USB 3.0 in September 2009.
It worked flawlessly in my HP dv7 core i7, not so much so with my Asus.:(
If it hadn't been for the sandy bridge bug, I would not have this g73s.

05-26-2011, 04:48 PM
Also is 1 hour par for battery life?
Or is battery life lackluster on the first discharge?
I have the little cpu scaling monitor going and it stays mostly at 800 mhz.
May be the display, becasue it does not dim when the AC is removed.

Might have something to do with the WMI power management..

05-26-2011, 05:27 PM
The first discharge is lower, yes. However I think it could be because the display is not dimming and the GPU might not be downclocking.

As to USB 3, I still think it sounds like no device driver is running. I believe you that it is supported but either that function is turned off or it isn't recognizing the specific controller. I say this because USB 3 should be backward compatible. Basically your device should drop to USB 2 if USB 3 wasn't working, not refuse to work entirely.

05-27-2011, 02:25 AM
Soon as I plug a device in the USB 3 port, it locks up the laptop.
Other USB ports are fine.

Even a USB 2 device plugged into the USB 3 port locks it up.

05-27-2011, 01:25 PM
So actually you are complaining and you want to return your Asus Gaming Notebook (with emphasis on Gaming) because it doesn't work well in some random linux distro? A notebook for which the manufacturer provides driver support ONLY for Windows 7?

PS> The "New Revision Certified Design" sticker means only that you get the fixed revision of the Intel Chipset. An assurance, if you want to call it that way, that you don't purchase the bugged chipset that was manufactured by Intel till the January 2011 and was subject of a massive recall.

PS2> sorry that my first post here is actually a rant and doesnt not provide any useful information, but i could not hold myself...

05-27-2011, 02:49 PM
It's OK manu, you are correct that ASUS never really intended for this to be used in Linux. It's not that ASUS hates Linux, just that it's such a small market segment by comparison. It's just not worth sourcing different (potentially more expensive) components and performing testing to certify compatibility. And that's exactly wreker's problem. Linux is a small market so it really doesn't get much love from anyone. Finding a high performance desktop replacement that runs Linux well can be downright frustrating.

05-27-2011, 04:04 PM
I'm well aware of that, but what stirred me on was the "it doesn't do what is not supposed to do so i'm sending it back" instead of something along the line: i know asus doesnt provide drivers for linux, but i really need to make it run under linux... and so on and so forth...
He can get help more likely with the latter approach instead of the "Even More Awesomeness NOT" approach.

05-28-2011, 10:20 PM
Yeah, I guess I was mistaken thinking that because USB 3 is a standard, and worked fine on the HP Sandy Bridge Core i7 with some random Linux, then it should work on the Asus Core i7 with that exact same random Linux?

05-29-2011, 06:12 AM
Yeah, I guess I was mistaken thinking that because USB 3 is a standard, and worked fine on the HP Sandy Bridge Core i7 with some random Linux, then it should work on the Asus Core i7 with that exact same random Linux?

Even though the protocol is a standard the individual devices will vary and may require different drivers. Disk controllers, ethernet, blue tooth all have the same problem. You can move your hardware and connect to any system because of the standards but underneath there's no one driver that works perfectly for all controllers.

05-29-2011, 04:03 PM
to get FL1000G USB 3.0 Host Controller working I had to add a line to grub2.