View Full Version : G73jh-1a Hd 5870 update

10-24-2012, 07:26 PM
Ok i updated my bios with the flash tool, it says 213 now.

I made bootable usb drive, autexec didnt load right and they said the config.sys was wrong somehow but I got a boot prompt and ran the vflash. I updated my vBIos its at

Now to update the aging 2009 Hd 5870 driver . . . nope. When I ran Catalyst Control center 12.10 it said "windows could not digitally verify the device because of a recent hardwar/software change", The bios/vbios? So I went looking for the CCC that old posters who wanted to upgrade their hd 5870 driver. They said CCC version 10.8 worked, but all I could find was the non-mobility version, im guessing thats for desktops. Gsods getting worse now on new games that I clearly pass requirements for. Anyone know the latest driver that wont give me a blue screen?

10-24-2012, 07:31 PM
bios & vbios are two different things. vbios refers to the video bios which is what causes the GSOD for many people. While updating the bios isn't a bad idea, it won't fix a GSOD problem. Look at the vbios thread here on the forum for more info on updating that.

10-24-2012, 09:35 PM
Yes, even after system restore my bios is still updated to 213 and vbios is now

I just want to find the ccc mobility driver that I found most people had success with which is the 10.8

10-24-2012, 10:04 PM
Ah sorry, I forgot that the vbios version is reported differently depending on where you are looking. That G730 looked wrong to me but never mind, that is correct.

As to the mobility driver, I forget which one I have installed. I'll see if I can remember to check.

10-27-2012, 03:45 PM
My last attempt I remember uninstalling the old driver and installing the 12.10 Catalyst control center. But only installed the "driver" and nothing else. The system crashed to blue screen during installation as usual but when i restarted and went to my device manager. It reads

Provider Mobility Radeon 5800 series
Made 09/27/2012
Version 9.20

Device is working properly

errrrr, should i mess with this? I finally got it installed but I'm pretty sure thats NOT the way to do it.... I just downloaded the driver cleaner and wondering if I should even make an attempt to PROPERLY install the current drivers or should I just count myself lucky and move on?