View Full Version : Touchpad Driver not recognized, tried both

10-27-2012, 01:15 AM
Hello again ROG!

Just reinstalled W8 On my computer, got the pro version and all now.

Only problem so far has been the touchpad driver. I pulled the one out of my driver folder from the preview edition of W8 and I get this error:
"this driver version is inapplicable for the touch pad. Please check the devices on the system, and then install the suitable driver."

Reading that message, I got the older version of the driver.. I've tried both and from the thread (http://rog.asus.com/forum/showthread.php?5224-Drivers-Apps-and-How-to-s&country=&status=)

tried run as admin and restarts.. tried compat. mode. no dice.

and to clarify with Synaptics I get "synaptics device not found"

Any ideas? Thanks guys.

10-27-2012, 01:21 AM
Hey lxPanda! Since you're using the W8 pro, by chance had you tried the fix I posted in my Windows 8 Thread? It's this exact issue :D I have the Sentelic Touchpad, which I'm guessing you have as well


11-06-2012, 03:31 AM
ASUS not support Windows 8 Driver for G74SX NB, Did you try install G75 touchpad driver for Win 8 to G74?

11-06-2012, 04:16 AM
Hey Mike, this problem was already taken care of, as all you have to do is just install the driver manually through the Device Manager :D