View Full Version : Win 8 PRO upgrade: How to keep your ATK On-screen stuff and Power 4 Gear!

10-28-2012, 02:28 PM
Hey Guys and gals!

I just did my upgrade and I'm HAPPY to report that I have both Power4Gear and ATK things functioning. The key step that lets you do this is upgrading vs. a clean install. I upgraded from Windows 7 using Microsoft's deal and after ~35min got it all finished. Keyboard backlight, screen brightness, and volume controls ALL SHOW SCREEN OVERLAYS. All of my hotkeys work. Additionally my power settings were carried over and I'm currently set to Power4Gear High performance. I wanted to be sure people knew that you CAN keep these, many posts stipulated that you couldn't but those users had either installed the RT or had done a clean install.

Dennis St. John
10-28-2012, 05:03 PM
If you do a clean install, couldn't you just install the Win 7 driver package for these components, or does that not work and what we're still waiting on from ASUS?

10-28-2012, 05:27 PM
I reinstalled the ATK Win7-drivers after upgrading to Windows 8. It seems to be working fine to me.

10-29-2012, 01:51 AM
If you do a clean install, couldn't you just install the Win 7 driver package for these components, or does that not work and what we're still waiting on from ASUS?

That is what I did.. no problems so far.

10-29-2012, 06:49 AM
Well I did a clean install, and what happened was that the WiFi driver gave me blue screens every time I restarted the computer, so I had to re-install Windows because of it. Then I left it out because Windows had drivers for it out of the box anyway so it could work without the driver. My Hot keys wouldn't work unless I started the HControl.exe file in the ATK Package install directory. My touch pad wouldn't auto run every time I booted my computer (still worked if I started it myself). Power 4 gear Wouldn't start at all no matter what! And my USB 3.0 drivers are still not working. I am using a G55 and did a clean install on my brand new SanDisk Extreme SSD. I really doubt that everything is working for you but if I am wrong please explain in details how did you make everything work!

10-29-2012, 07:48 AM
@ggBanks, the wifi induced blue-screen was mentioned here (http://rog.asus.com/forum/showthread.php?24535-UEFI-and-Windows-8-help&p=175619&viewfull=1#post175619). the solution is here (http://rog.asus.com/forum/showthread.php?24535-UEFI-and-Windows-8-help&p=175658&viewfull=1#post175658), along with Power4Gear. the visual indicators are still missing (ATK package). you can try to install this one (http://nbtsd.asustreiber.de/Tools/ATK%20Package_V1.0.0023.zip) (all fn combo keys are working for me).

10-29-2012, 07:58 AM
Thank you rewben I must have missed these updates somehow. And for me the old ATK Package is working except the touchpad button, but that is not a big deal for now.

P.S. I tried the Power 4 Gear and it seems to be functioning properly, but I cannot change the plans with the designated button for it, and this version doesn't seem to have the disable Optical drive like the last one, which I was looking forward to testing if the problem with my HDD in the caddy will be fixed :(

10-29-2012, 08:32 AM
theoretically, the system should have detect that it is a HDD instead of optical drive. i am not sure about this but did you try to set in the power plan to NOT put the HDD to sleep?


i am using SSD in the caddy, so it seemed fine to me.

10-29-2012, 09:04 AM
Yes I did it! And you can't notice it in your case because the SSD isn't using moving parts and you cant hear it when it stops working, but when in a quiet room I can hear my HDD spin down after around 60 seconds of being idle. And when I watch videos from time to time just for a second or two the disk seems to get overloaded (not sure about this one) with requests by the system somehow and maybe that causes it to lag with the videos. It looks like a hiccup like the video is running smoothly then for the period of 1-2 seconds it looses half of its frames and the audio somehow gets distorted, but after those 1-2 seconds it goes back to playing the video properly.

10-29-2012, 10:28 AM
hm.. it's kinda weird. i thought the system should have detected that the disk is active (watching videos should mean near constant reads).

10-29-2012, 12:38 PM
Yes during the watching videos it is active, but still... idk why it's like that :(

P.S. I just went into the BIOS and I saw that the boot priority says:

1. SanDisk (*model*)

It doesn't see the HDD there, it thinks it is an optical drive. It should have listed the model of the HDD like it does with the SSD right?

P.S. P.S. It does recognize the HDD model in the boot option menu which is separate of the BIOS though.

1. (*SSD model*)
2. (*HDD model*)

P.S. P.S. P.S. Ok here's the latest news. Under the Boot tab in the BIOS I changed the Launch PXE OpROM to Enabled, and now in the boot priorities no longer says:

1. SanDisk (*model*)

but it says:

1. SanDisk (*model*)
2. Atheros Boot agent

I don't know what happened but still I think its better.

10-29-2012, 01:18 PM
uh? which is which?

iirc i have deleted the DVD entry previously. i only have one option for boot priority for now, that is my OS drive.

10-29-2012, 01:27 PM
I tried the delete option and it said there is nothing to delete. Really I don't understand. :confused: In the security tab I went into the I/O Interface Security and locked the SATA ODD Interface, but when I went back to windows the HDD in the Optical bay was disconnected. I thought this might solve my problem but apparently it didn't. And one more thing is that one entry above the SATA ODD Interface it says SATA 2nd HDD Interface (this is my SSD), but nowhere else is mentioned a 1st interface. Why doesn't it say 1st instead of 2nd interface there?

And I was wondering what is this PXE OpROM ?

10-29-2012, 01:49 PM
1. i forgot how i deleted the entry, sorry. the bios in g55 is quite tricky to play with sometimes.
2. pxe is a network-based boot option. you do not need to enable it.
3. locking odd interface literally locks the access to it.
4. g55's 1st interface is mSATA, which is kind of useless when you're thinking warranty haha!

10-29-2012, 01:55 PM
Ok thanx, I will disable the PXE stuff. I was wondering by the way does UEFI have more options than the normal BIOS, and how can I boot in it?

P.S. I disabled it and now my SSD is in the boot order but the second option is gone so now its only my SSD
I don't know what happened but I think I will stop playing with it. :D

10-29-2012, 02:23 PM
er.. g55 has a limited user functions for uefi. my windows is installed in bios mode, i cannot tell you much about it.

if things have gone wrong, you still can reset all to defaults :)

10-29-2012, 03:29 PM
By the way did you manage to fix the 2.14 version BIOS or did you revert to a prev version?

10-29-2012, 03:43 PM
214 failed on me :/ running on 209 now. my power button was unresponsive when my bios was 214; i tried a fresh install but my machine was unable to restart on first boot.

however, there are users that reported no issue with their machines.

01-04-2013, 05:46 PM
update: found a possible solution to enable the onscreen stuff (http://rog.asus.com/forum/showthread.php?27227-Asus-G55VW-IX044V-with-Windows-8-Pro-FN-keys-and-Backlight-Problem&p=206257&viewfull=1#post206257). please try it out.

05-03-2013, 11:31 PM
People, I have a G75VW and same here, only touchpad enabled/disabled function is showing on screen image, keyboard lights do not even work and P4G Hybrid does not show any on screen images, when I press the ROG button it opens up the P4G program itself instead of changing states. Any ideas ?

06-21-2013, 05:45 AM
update: found a possible solution to enable the onscreen stuff (http://rog.asus.com/forum/showthread.php?27227-Asus-G55VW-IX044V-with-Windows-8-Pro-FN-keys-and-Backlight-Problem&p=206257&viewfull=1#post206257). please try it out.

try what out?