View Full Version : Two G75's with the same Atheros-AR8151 major UPLOAD SPEED problem? Qualcomm V2.1.0.12

10-29-2012, 11:00 PM
I have the G75VW-DS73-3D. Has anyone seen this problem please?
The Atheros AR8151 PCI-E Gigabit Ethernet Port has a major UPLOAD SPEED problem!

The upload speed is capped at a mere 0.1 MB /SEC, it should 100 times faster 10 MB / Sec!!! Note 1, the download speed is perfect! Note 2, the Wi-Fi upload & download speeds are perfect! Note 3, its not a unique fault with my G75 as a 2nd working G75 has same problem! Slow uploads are apparent when uploading data to the network, such as running an UPLOAD INTERNET SPEED-TEST, or COPYING A FILE to the network. Its also apparent copying files to a NAS storage driver or a 2nd directly connected PC. Because of Note 3 I want Asus to replicate this problem and troubleshoot it. I don't want to RMA!

Here's what I've tried.

#1. Updated Driver but Asus site only had V2.0.8.8. Found post with Qualcomm V2.1.0.12. Same problem!
#2. Used several new LAN cables. Same problem. Slow Upload! 0.1 MB / sec
#3. Virus checked the G75. No viruses found! Slow Upload! 0.1 MB / sec
#4. Turned off the virus-checker / firewall. No difference! Slow Upload! 0.1 MB / sec
#5. Selected high-performance Power mode. Still Slow Upload! 0.1 MB / sec
#6. Tested using a 2nd identical working G75. Same slow upload problem! 0.1 MB / sec
#7. Tested network using a HP laptop running Windows 7. Its fast! Upload speed: 10 MB / sec
#8. Tested network using an Asus EEEPC running XP. Its fast! Upload speed: 10 Mb / Sec!
#9. Tested using a NAS storage drive directly connected to the G75. Slow Upload: 0.1 MB / sec.
#10. Tested connecting the G75 directly to 2nd G75 or the HP. Slow Upload! 0.1 MB / sec
#11. Ran a G75 Wi-Fi versus Ethernet cable test. Wi-fi copies at 2-3 MB / Sec as expected.
#12. Substituted the Router a UBEE, for a Cisco. Same slow upload problem: 0.1 MB / sec
#13. Tried changing TCP Tuning Settings. Same slow upload problem! 0.1 MB / sec
#14. Altered Atheros Device Manager settings i.e. Speed and Duplex. No difference! 0.1 MB / sec.
#15. Searched internet for known Atheros Upload speed problems. Nothing found that fixes the problem!

10-30-2012, 02:50 AM
what antivirus are you using?

10-30-2012, 06:22 AM
Actually there's none on either machine. I uninstalled the default bloatware on receiving both G75's! I do download the latest AVG, Trend Micro or Sophos on put them on secondary computers to scan files I don't trust. But I completely leave them off the G75 for performance reasons and because of the G75 hangs and freezes thread on this forum. Java, Flash, and Javascript are also disabled on both G75's...

The router is locked down by the ISP but I fear I've overcomplicated this posting so can we simplify it because we're getting away from the real problem I fear... Imagine my home network has no router, just 4 isolated computers and a WD-NAS...

#1. New G75,
#2. Old G75,
#3. HP (Win7),
#4. EEEPC (XP),
#5. WD NAS 'My Book Live'!

Imagine I only ever connect the WD NAS to each machine individually and directly using two different LAN cables, and run two tests copying from and then to the WD NAS. I'm finding the cables are making no difference to the speeds, these are the actual speeds that I get :-

New G75 + WD-NAS -> Download 10 MB / Sec - Upload 0.1 MB / Sec
Old G75 + WD-NAS -> Download 10 MB / Sec - Upload 0.1 MB / Sec
HP +WD NAS -> Download 10 MB / Sec - Upload 10 MB / Sec
EEEPC + WD NAS -> Download 10 MB / Sec - Upload 10 MB / Sec

I'm quoting from the Win7 copy screen which lists about 50-100 KB for both of the G75's upload speeds, whereas the HP and EEEPC are uploading at 10 MB / Sec. The copy dialog is clear no mixing-up of the units!

Regarding patching the Atheros. The installer options are quite fixed. I just did a REPAIR the first time then did a test, then a modify the second time to be sure it had installed. The driver says its updated. But remember the New G75 still has the older driver, but both machines still exhibit the slow upload speed problem when compared to the HP and EEEPC!

10-30-2012, 11:28 AM
But I completely leave them off the G75 for performance reasons and because of the G75 hangs and freezes thread on this forum.

A couple of things:

1) Please do not jump in on 3 or 4 different threads with the same problem. Keep 1 thread with your problem ... the more threads you post in about the same thing the less likely anyone will help.

2) My G75VW works just fine ethernet ( and wireless ) so it is probably software or firewall or some config problem in your network.

Looks like I am running non wireless driver dated 9/19/2011 for driver. Yup thats the only one asus has in downloads for G75VW must be original.

3) If you want to rule out hardware put in spare drive and put linux on one of your machines and test it out.

10-30-2012, 12:42 PM
Yes, sorry I posted to 3 threads as I couldn't decide where to begin on here. Delete this thread if you need to Admins, but please leave the other two alone for a day or two, if that's ok?

John, I'm technical but its been a few years since I dual booted or hot swapped in a second OS, I have no idea where to start to get this puppy up on Linux. How much work am I looking at?

I have two G75's one running the original shipped drive, that still is the most current on the Asus website, and the 2nd G75 has the more recent Qualcomm Atheros driver But its the same problem on both, but the laptops were not sourced at the same time... Surely there's an Atheros diagnostics or Asus utility to test this before going to the point of installing Linux...?

Myk SilentShadow
10-30-2012, 12:55 PM
This may be a way off base question...but are you using 1 channel for your Wireless or 2?

10-30-2012, 01:38 PM
Yes, sorry I posted to 3 threads as I couldn't decide where to begin on here.

Well we do not see much active work here by the forum admins ( except at times to purge spam ) so unfortunately probably all the threads will continue to see updates and different advice.

My shot in the dark guess is it is not hardware or drivers ... some other software thing or config thing ... just guessing ...

I guess I would disable the wireless first and keep isolating the ethernet connection.

Go somewhere else maybe and use a different ethernet switch ... maybe something in your equipment at home?

Get some packet sniffer software going perhaps if you want to keep troubleshooting in windows.

Otherwise I would think about pulling out your current drives in the G75VW and installing something recent in the linux 64 bit on a spare drive and do some trouble shooting on a different OS. If ethernet works just fine in a different OS it is not hardware ... pointing back to some software/firewall/antivirus/rootkit on your system.

I for one do not understand trying to run any system these days unprotected ... my G75VW has both NIS and MBAM and the combination takes almost no overhead.

Sounds interesting anyway!

10-30-2012, 01:42 PM
My ISP owns the router and has it locked down tighter than the Town's Gov'ner in this week's episode of 'Walking Dead'!
Hence I can't answer that as even the read-only diagnostic tools for the UBEE 2110 are unavailable to the home user!! I can assume the answer is 1, but can't confirm it, sorry.

but none of this gets to the heart of the problem though... i..e. Connecting a WD-NAS directly to either G75 produces an upload speed of 0.1 MB. Whereas connecting the HP or EEEPC to the WD-NAS produces 10 MB or about what might be expected via LAN cable versus USB 2.0...

10-30-2012, 02:06 PM
i am not sure if these helped:

1. can you try this (http://www.sevenforums.com/network-sharing/2503-extremely-slow-file-transfers-network-access-4.html#post1622263)?

2. another one is this (http://forum.avast.com/index.php?topic=88532.15).

this is a weird case though.

10-30-2012, 06:18 PM
Yes I don't recommend going naked into the night. But there is some method to my madness in an imperfect world :-

I'm a cynical ba-st-rd. cynical enough not to rely on security software. Why? Because I've sat in meetings in Fortune 500 conference rooms where security reps freely admit retail versions of their products are impotent. At the very least security software must be hosted on dedicated serves monitoring the network 24-7. When there's an update, the B-Servers, take over from the A-Servers. At home however, the PC is simultaneously the watcher, the playful child and the updater. What kind of Security Model is that?!

The real world is very gray and my family & friends are much too lazy to UPDATE security software cos its not sexy like Facebook! That's real bad news for me as the go-to-tech-guy. So I tell them buy two cheap net-books. A virginal one for online-banking etc, and an expendable one for Flash / Java gaming and randomly surfing the web. The kids can even hard-power-off Mr expendable during a virus update and no one will lose sleep!

But having two machines sometimes isn't practical. Having two different browsers however is. Browser-1 comes fully loaded with Flash & Java plug-ins on Chrome or IE etc. Browser-2 comes fully unloaded i.e. Firefox running in private mode with no Javascript! You mostly surf your favorite websites in Firefox using simple HTML, using the loaded browser sparingly and with caution. Its cost friendly for prepaid 3G too! For email Gmail has virus checking etc.

But the Achilles heel here is what about new software installs? This is especially important with regards to online banking.. So I advise using well-maintained corporate networks only. Where not possible then avoid accounts that allow outside transfers without added security dongles or key-code-devices. Credit cards? Most have protections, so few worries there. Whereas with Paypal, is there still no hardware security?

My day job is programming the web using MS. Net. Its a multi-vendor, multi-tier world where websites are often hacked in-turn infecting loyal users. Its getting worse, no matter what security software you have. From time to time before installing something new, I download security suites on demand, so I can be bloody sure I'm getting the latest patches and updates. I've seen Updaters fail silently in the background trying to update a sub-system. Its quite common. The only hint of a problem is buried in the system logs or an obscure log file under a long path name! Symantec is the worst for this IMHO.

Now, I have a feeling that maybe I should go off and duck and cover....? :)

10-30-2012, 06:54 PM
Well the achilles heel is zero day exploits of microsoft/3rd party software and attacks over any network or even wifi connections.

As imperfect as all the security layers are ... having none ... and thinking you have some kind of good system to control it all ... sorry I just don't buy it.

Try doing some testing of your old G75VW using a bootable flash drive with a recent linux flavor and see what you can find out about your ethernet hardware.

Like I said ... mine works fine sounds like pretty much same notebook and same driver ... so I don't think you are going to get far trying to volley this into asus for investigating/fixing ( but hey good luck with that anyhow! ).

Well ... of course booting off a flash drive ... well that's dicey right?

"Well-maintained corporate networks" ... dang you are hurting me man! I only wish there were such a thing! Maybe 20 years ago ...

10-30-2012, 07:21 PM
Rewben, you are a true Hero!!!!

Fix from 'Slipperx' on the Avast forums :-
"One more thing that makes a significant difference is to go to Device Manager and open the propoerties for the Network Adapter, click the Advanced tab and disable Large Send Offload (IPv4) and enable Large Send Offload v2 (IPv4). "

I wonder why two factory shipped G75's (one new in virginal state) have been configured wrong and Asus didn't spot it?
I checked a 3rd Windows machine that was working, a HP, and it had Large Send Offload v2 (IPv4) enabled!

10-30-2012, 07:28 PM
"As imperfect as all the security layers are ... having none ... and thinking you have some kind of good system to control it all ... sorry I just don't buy it.'

I'm just lazy....

10-30-2012, 07:30 PM
Is there a way to close out the thread?

10-31-2012, 01:36 AM
wo it worked?! i have no idea what were fixed because my atheros ethernet has Large Send Offload v2 (IPv4) enabled, too :/

10-31-2012, 06:27 PM
Didn't quite catch that...
On your Asus or Asus G75 :-
... you have Large Send Offload v2 (IPv4) enabled, correct?
... and Large Send Offload (IPv4) is disabled or enabled?

10-31-2012, 07:07 PM
wo it worked?! i have no idea what were fixed because my atheros ethernet has Large Send Offload v2 (IPv4) enabled, too :/

It looks like several low level network adapter settings ... where changes to any of them ... and the impact that has ( if any ) ... is heavily dependent on what kinds of other network hardware and speeds one is hooked into.

Settings as asus delivered them are probably fine for many/most? people.

10-31-2012, 10:51 PM
Agree John its looking that way. I had read posts before posting on ROG that claimed changing the Speed and Duplex settings in the same Device Manager -> Atheros -> Properties box fixed it for them. I also read about people running a command line TCP Tuning request which also fixed it for others. This also makes me wonder too what else is being affected?! Tricky problem to solve, and it should have been easy really...

11-01-2012, 01:35 AM
sorry what i meant was mine works out of box, default settings (for my machine by default they are Large Send Offload v2 (IPv4) enabled, Large Send Offload (IPv4) enabled; no issue).

yeah i think it's like what john pointed out. i always thought these hardware, its drivers and settings should have standards to follow (it's a plug-and-play world; at least it has a auto-switching mechanism/profiles to play with), but apparently still not possible to all of them lol!

11-01-2012, 05:13 PM
Interesting. So one theory could be, at the time of building, they had a patch to run after the imaging was complete that a badly trained probably outsourced tech forgot about on batches of G75 machines from April 2012..... Perhaps the same untalented uninterested tech that works at Asus VIP support...

You know I wrote 50+ emails over 3 months to the bullsh*t VIP Asus support. That 50 includes replies and creating new repeat cases in the hope of getting someone knowledgeable. Not a thing! Week after week a single reply would come:

‘swap the LAN cable’ "for a try",
‘get a new virus checker’ "for a try",
‘try a new router’ "for a try"

.... You get the picture. They like that phrase "for a try". Actually it sums up their amateur have-a-go attitude to troubleshooting. They never ever try to replicate problems, they just read from a script and refuse to escalate anything to 2nd tier support! Invariably cases end with ‘go get an RMA’ which wasn’t possible- see below..

Whereas you talented guys on ROG solved this problem in one or days! Its difficult to comprehend how a $2000 laptop can have such sh*tty outsourced support…. And don’t get me started on the irony of using the term VIP!!

I’m unlikely to buy Asus again, which is a pity as I loved their netbooks and got many for friends and family. Their EEEPC’s were so simple to use, had limited bloatware but had tough construction. I took one all over the world travelling for 3 years. I just shoved it into a packed backpack. And while the screen now goes red or blue when I move the hinges, the damn thing still works. I'm typing on it right now and It rarely ever crashes, and when it does its probably a memory leak in XP!

Whereas my G75 would crash once or twice a day in a fatal freeze that was impossible to trace but likely to be a faulty GPU / Motherboard / Memory issue or a critical patch like the Atheros one, that wasn’t executed during the build! But I was stuck with the G75 because the supposed 2 year international warranty is only as international as Mexico, Canada and the US. And I thought congress had poor awareness of foreign relations!

11-02-2012, 01:59 AM
Rewben, you are a true Hero!!!!

I agree - You did some good detective work on this case, @Sherlock!
;>{) >

11-02-2012, 02:52 AM
I agree - You did some good detective work on this case, @Sherlock!
;>{) >
@dstrakele, lol! it really is some detective work; took me quite a while to look it up before i could get only 2 possible solutions with similar issues.

@g75owner, now i understand why you sounded so pissed off in your previous posts haha; your case is really rare, maybe that's why they were not aware of it from the start and couldn't give a sound advice to you.

as for the support, it's a common problem. many big companies are aware of that but none show significant improvements. i must say given a 2-year warranty, that period of time is more than sufficient to make a customer to be loyal or to look elsewhere.

since your g75 has some many issues, i think it's worth the while to send them for RMA. record every issue in details and put them in the desktop, and ask the support to read/watch them. a g-series should not act that way. my g55 is good (except for the latest bios update). it never crash (all bsods are induced by my mistakes only).

11-22-2012, 05:46 AM
Thanks again Rewben! Before the fix I had a copy speed of kilobytes-- no kidding! Now I’m getting 50 MB / sec backing up to a WD NAS drive connected directly by LAN cable. So it makes backing up 2TB more than a little bit easier.

Before I had feared the Atheros port on my G75 had chip failure. It was only after I received a replacement G75 from Asus, that I knew there had to be something else going on! Incidentally both G75’s are buggy, they routinely hang, freeze and lockup requiring a hard reset! Its curious that both laptops also have the same Atheros bug as well. So far it seems other G75 users have faired better, judging by the lack of posts about this! Did Asus forget to run a patch or update before shipping these two I wonder?. Or are the two issues separate, and the hangs solely due to a bad batch of Nvidia 670m's? I still don’t know. Maybe I’ll do a separate post on this and take a casual survey..?!

11-22-2012, 10:16 AM
@g75owner, you're welcome. good to know that you have great speed now :) yes, your case is a rare one; so far i haven't found another similar one in the forum.

if your system is still experiencing problems, have you tried run 'sfc /scannow' in elevated command prompt? the next two options might be doing recovery or clean install. a g75 shouldn't act that way.

11-22-2012, 04:53 PM
Yes had tried sfc /scannow run as admin as I'd seen it suggested on another forum. No joy I'm afraid. After 6 months of troubleshooting, I'm sure the hangs are due to a buggy Nvidia 670m. So a bad batch of G75's is at work here I suspect. Asus have been all too silent on this though. But I now suspect they sent me a refurbished G75 as a replacement, one with the same problem albeit less severe. Now that I have a 2nd G75 to play with I'll be trying the latter two options you suggest. Cheers Rewben!

11-23-2012, 01:36 AM
six months for trouble shooting?! now i really think you're one of the most patient persons in this forum.

and good luck to you :/

10-04-2013, 03:41 PM
My own problems were solved by downloading the drivers from here, rather than from Asus or Atheros:


07-29-2015, 07:22 PM
My own problems were solved by downloading the drivers from here, rather than from Asus or Atheros:


@Speranza, you wouldn't happen to be able to share the drivers you downloaded, would you? Qualcomm has changed their site, and I can't find where to download any drivers at all.

This problem has resurfaced for me. I was on another thread about this issue, and it was solved for me. Now, for some unknown reason, I keep getting pathetic upload speeds. I have to go through the whole advanced settings changes, reboot, try again cycle a few time a day. It's incredibly frustrating.