View Full Version : Touchpad problem

10-31-2012, 11:00 AM

I bought my G75VW about a month ago and it has worked fine so far. However, few days ago I discovered that my touchpad doesn't work properly. Usually I use an external mouse so I'm not sure how long I have had this problem. I'm positive that it worked when I used it for the first time.

The problem is that the left mouse button doesn't work and none of the multi touch gestures work (including tap to click). I can move the cursor and click the right mouse button but that's all.

First I thought that there must be some problems with the drivers, so I downloaded the new ones from Asus. It didn't help. I tried fiddle with the settings -no help. I even restored the laptop to factory settings with the cd's but it didn't fix it. So could this be a hardware problem? It's really odd because I haven't damaged my laptop in any manner. The only modification that I have made is that I have installed a ssd.

Currently I'm using Synaptics TouchPad V7.4 (v15.3.43) and I think those are the latest drivers. So, any suggestions? Or should I contact my retail store for warranty?

Sorry about my English.

10-31-2012, 11:10 AM
i know exactly what you are talking about, there is nothing you can do. the semitic touch pad is a known hardware issue. just google it you will see. mine was acting up within the first few days i had the computer. but like you i use a mouse as well, so i was not aware of how bad it was for awhile. my computer was about 2 months old and i had to send it in for hdd issues and i had told them about the mousepad and as usual per my experience they brushed it off and said the warranty doesnt cover the mouse pad. when i asked what the warranty was good for they insisted it was only for software. either way good luck 2 you. the mouse works fine for me just annoying when on the move, hence having a laptop, but hey thats life. good luck