PDA

View Full Version : Windows 8 Issue and Resolution



HumanityPlague
11-03-2012, 06:42 AM
I wanted to talk a bit about my own Windows 8 process, and detail the problems/solutions I came up with, when trying to get Win 8 on my Asus G75 model. Hopefully, this might help someone else down the road:

I grabbed Windows 8 Pro from MS last night. After making a DVD, I tried a clean install (but wanted to keep my apps/files). I was told to do that while in Windows 7.

Once in Windows 7, it went through the launcher and told me to remove various programs/drivers. Notably, Daemon Tools Lite, Winamp, the Atheros Bluetooth Suite, the AMD Dual-Core Optimizer (I dunno what this is, to be honest), Expat Shield, and the Intel USB 3.0 eXtensible Host Controller Driver. Setup wouldn't let me continue without me getting rid of this stuff (except Winamp where it said "Well, you can take your chances).

Once the installation went underway, it took about an hour and 15 minutes to install it. I was at least half way in my 2nd episode of Dr. Who, for time's sake.

The start menu popped up, I went through the various logins and such and the start menu came up....at around 800 by 600 resolution. I checked the drivers and the Nvidia drivers I had been using weren't there anymore. Everything else seemed to be working, the webcam, sound, wireless network, even the Bluetooth stuff.

So I went to Nvidia's website, downloaded the 306.97 drivers for the GTX 660M card and went to installing. When Nvidia's launcher popped up it said that it had detected my previous install of the software, and asked if I just wanted to upgrade it, or do a clean install.

I choose to do a clean install, and after about 10 minutes, it restarted, and my normal resolution was back. Eager to play a game, I booted up Pinball FX2 and didn't hear anything. Perplexed, I looked at the volume control and saw a big red X on it. I clicked it open and saw that it didn't detect my speakers anymore, and that instead of the usual 4 things listed in playback devices (Digital Audio, Digital Audio, Speakers, and SPDIF Interface), only two were listed (both Digital Audio options).

I tried searching for the speakers on the system, where Win 8 said "Uh...what speakers?" I came on here, and saw some of the posts about how the VIA driver wasn't done yet, but that Asus was working on it.

Annoyed by this, I was getting ready to start backing up everything to do a fresh install of Win 7, until I realized that I *did* have sound earlier, before I installed the Nvidia drivers. That seemed to the culprit that wrecked my speakers driver.

I found a system restore point, and restored to that (it was an app restore point), that was prior to the Nvidia driver installation. That also took about a solid hour to do a system restore. When the computer finally booted up, I was back at 800 by 600, but DID have sound. I went through the Nvidia installer again and instead told it just upgrade the old drivers to the new ones. It went through the same process, but messed up at the end. The driver package didn't seem to install every part of the software, I had about 2 or 3 red X's, of the 7 listed things it installed.

Worried now, I rebooted, and when Windows came up, it was back at 1920/1080 (default Nvidia reso.) and the Nvidia program was listed as being installed. I also had my speakers though, which was a bit odd. More than that, I seem to have everything else, my subwoofer *does* work (and can be controller with the HD VDeck thing), I have my Function key icons that display fine (like FN and F2 to flip the Wifi on and off), My USB ports do work, but I don't have anything that is USB 3.0, so I don't know their speed.

Hopefully this helps someone out there if they decide to upgrade to Windows 8. If you do upgrade to Win 8, and the Nvidia drivers don't carry over, make SURE to create a hard restore point, prior to your installing them. Make sure (with this point) that you do have sound. If the Nvidia driver blitz's the sound card driver, then you can restore to this point and try again. Cheers.

madnj
11-03-2012, 05:30 PM
Umm, there absolutely are VIA sound drivers that work for Windows 8, so it definitely seems like you did some excessive work.

I probably would have just run the VIA drivers install after installing the NVidia drivers and I'm pretty sure it'd have worked just fine. I prefer clean OS installs anyway though for new OS versions, so that's what I did.

HumanityPlague
11-04-2012, 02:03 AM
I *did* try that, downloading both VIA driver files from their website. The problem with that was that the Nvidia update completely wiped any of my sound card info. Both driver files got stuck when trying to find my sound card, since my PC didn't detect them anymore. It literally grayed out the "Next" button, because it didn't recognize that I had any hardware installed. Hence why I had to do the system restore (to get the audio driver back).

Pitcher@asus
11-09-2012, 02:47 AM
hi, did you try install driver from ASUS website, and it have teach correct way to upgrade driver form Win7 to WIn8.
http://support.asus.com/download.aspx?SLanguage=en&p=3&m=G75VW&hashedid=gkyI9iViQxXxueTd