View Full Version : wimax connection utility

11-08-2012, 04:05 AM
I have a G74sx bbk8 with an intel centrino 6150 wimax/wifi card built in. The notebook came with a Best Buy Connect utility that would let you search for a wimax signal or wifi signal. The Best Buy Connect 4g service was shut down, and i was given a chance to switch over to Clearwire. Evidently, Clearwire owns the first 4g network, so going with Best Buy Connect was a way to get clearwire service a little cheaper. When i switched, the utility i had would no longer connect to 4g, and Clearwire had a link to the new utility. Everything went well until i did a factory reset on my laptop. The Best Buy Connect utility was back, wouldnt pick up a signal, and clearwire told me to go to intel or the notebook manufacturer. The intel drivers would install the drivers for the wimax device, but i still couldnt find the utility anywhere. The Asus drivers installed the Best Buy Connect utility again, which is now useless.

Im a trucker, and this is the only broadband on the road thats worth anything. Any other wireless plans have 2 to 10 gig limits, but with this ive done 50+ gigs in a month with no issues. Performance varies from place to place, but its worth it.

This is the second time ive done this to myself, and i cant remember how i got the new utility last time. I remember trying some things i had already tried because no one could help me. The Geek Squad told me to use the warranty and mail it in for repair...

This time around, i want to know whats going on and why a simple program is so hard to find. Going through this again isnt an option, a week trying to fix something like this is crazy. Sending it in for repair isnt an option, because i know that program is out there somewhere. This is killing me, please someone help me out.

11-08-2012, 05:44 AM
Did you already try those driver?

Intel WiFi Wireless LAN Driver Version V15.0.1.1 :
http://support.asus.com/Download.aspx?SLanguage=zh-tw&p=3&s=336&m=G74Sx&os=30&ft=19&f_name=WiFi_Intel_Win7_64_Z15011.zip#WiFi_Intel_Wi n7_64_Z15011.zip

WiMAX Wireless LAN Driver Version V6.5.1035.26
http://support.asus.com/Download.aspx?SLanguage=zh-tw&p=3&s=336&m=G74Sx&os=30&ft=19&f_name=WiMax_Intel_BBYCM30068_Win7_64_Z65103526.zi p#WiMax_Intel_BBYCM30068_Win7_64_Z65103526.zip

11-08-2012, 04:09 PM
Ive tried both, but no luck. it now just says that a newer version has already been installed. That may be the drivers i got from intel. I dont think it is though, because i uninstalled all my wireless drivers in an attempt to keep up with what each driver i install does. The second driver you listed has the original Best Buy Connect utility. This utility shouldnt be available, as BBC has been permanently shut down. Whether or not im just missing something obvious, Asus has a program for download that is completely useless and requires that the comp be restarted before uninstallation can be completed. Very annoying. I will keep trying whatever i can think of, and keep you posted.

I have tried all install applications in both of the files you mentioned. My next step is going to be a complete hard drive wipe and reinstall. A factory reset doesnt reset partitions evidently, but its a place to start.

What i think it is, is that the install utility isnt seeing wimax capable hardware, so only installs wifi tools. None of that is working now, so i guess ill follow up on that after my complete wipe attempt.

11-13-2012, 11:28 AM
i installed an older version of the driver. This one was not in the drivers given in this thread, nor from the ones i got from intel. i have the intel centrino wimax 6150 btw. the path i found the right driver in is c:/esupport/edriver/software/wimax/intel/intelwimax_bbycm3.00.68_combine/win7_64_6.5.1035.26/channel/install

the file is "Intel wimax". the important thing to look for, there are about 4 of these same named files, is the date. you can simply search for "intel wimax" and pick the one with 6/6/2011 as the date. If its somewhere else, another main difference is it will be in a "channel" folder somewhere in the tree.

i had to uninstall all my wireless drivers first, otherwise it would state that a newer version is installed. you can uninstall the proset stuff to, plus go ahead and uninstall best buy connect.

asus gives you a file with some choices in it, but intel gives you an .exe file. it may be that the intel exe put the correct files where they are at, but im not sure.

the geek squad, bless their hearts, have been sending in laptops with this issue for warranty repair. best buy connect i guess was supposed to dominate the computer, kind of like a locked cell phone. they went out of bussiness, now they are losings gods knows how much in repair costs. when i last logged in to bestbuyconnect.com, it sent me to a web page that let me download the new wimax utility. it didnt say go to intel, or the laptop manufacturer, it just had a link. the site is no longer up.

the only things in this forum ive read regarding wimax all say ignore it, no one uses it. ive spent more than 20 total hours screwing with this issue. its been no help that the latest asus drivers only have the old bbc utility that picks up no 4g signal, no matter where you are. little pissed off at asus here.