PDA

View Full Version : G74sx 3d??



monsterism
11-08-2012, 03:00 PM
Hi

Brought an used G74SX and very happy with it, I did a fresh install of Win7 Ultmate and used this guide:

*banned website*

However, I know my device is 3D enabled since the glasses were included, but since wiping the machine what drivers do I need to enable 3D playback on the screen?. Plus also there was a ton of bloatware and 3D software before I formatted, how do I get a blu ray 3D software back again?

Thank

monsterism
11-08-2012, 05:23 PM
Can anyone please help?.

I know its the 3D model but I can't enable it, says 3D display not detected when it is. I'm really confused.

monsterism
11-08-2012, 05:59 PM
3D Mode Switch Key (on 3D models)
Toggles to activate the 3D mode function and again to switch
back to 2D mode. This function is only available when playing a
3D video game or watching a 3D movie.

Splendid Key (on non-3D models)
Toggles “Splendid Video Intelligent Technology” function ON
and OFF. This allows switching between different display color
enhancement modes in order to improve contrast, brightness,
skin tone, and color saturation for red, green, and blue
independently. The selected mode is shown on the display

OK i double checked and my screen does have a 3d emitter, however, I can't switch it on. Should be the switch key but it defaults to the spendid utility instead of switching the 3d on and off.

checkin the device properties even states its 3d?.

monsterism
11-08-2012, 06:15 PM
Sorry mean to clarify hit the prog button it switches power profiles and not as expected enable 3D.

dstrakele
11-08-2012, 06:57 PM
3D Vison is provided by the NVIDIA video driver. BIOS version 203 changes the ROG Button functionality to enable/disable 3D Vision. If you choose to upgrade your BIOS, see @BrodyBoy's guide: http://rog.asus.com/forum/attachment.php?attachmentid=6201&d=1329792574.

Be aware any problems during the BIOS update may render your system unusable. If you don't wish to update the BIOS, 3D Vision can still be enabled/disabled from the Windows Start menu.

Downloading SonicDVD from the ASUS website will get you Roxio CinePlayer to play Blu-Ray discs. I believe it is also present on the Applications and Drivers CD that ships with the G74SX.

monsterism
11-08-2012, 07:11 PM
Oh, HDMI cannot be connected when you want to use the laptop screen for 3D,.

PILGRIM
11-09-2012, 06:20 AM
...OK i double checked and my screen does have a 3d emitter, however, I can't switch it on. Should be the switch key but it defaults to the spendid utility instead of switching the 3d on and off.

Sorry mean to clarify hit the prog button it switches power profiles and not as expected enable 3D.

Basing on the behavior of your ROG button (next to the power button),
I assume you still have a 201 or 202 BIOS version.
The 203 BIOS makes the ROG button to enable/disable 3D Mode, as dstrakele mentioned.
No worries though, your G74 will still project in 3D Mode, in any of the BIOS versions.
All you need to do is to properly install any of the nVidia driver versions (suggest you install a newer version).
Just make it sure "3D Vision Controller Driver" and "3D Vision Driver" are included.

[If you care, this is how I install an nVidia driver:
-Manually uninstall all older nVidia drivers in Windows Control Panel (multiple restarts are expected).
-Restart computer, go to Safe Mode (F8).
-Use CCleaner software, then use Driver Sweeper, restart computer, go back to Safe Mode.
-Install the newer nVidia driver- go to "Custom" (Advanced), tick all components except "NVIDIA update",
tick "Perform a clean installation", click "next".
-Restart computer normally.]

Recharge 3D glasses (an hour or so). Then go to nVidia Control Panel > Stereoscopic 3D >
Setup Stereoscopic 3D > (tick) Enable Stereoscopic 3D > (click) Apply.

Then proceed in syncing the 3D glasses with the built-in IR emitter
by clicking "Run Setup Wizard". Turn on and wear the 3D glasses to calibrate.
By then, you'll see the IR emitter's green light appearing.
When 3D glasses are calibrated, exit nVidia Control Panel.

Open nVidia Control Panel again. Make sure "Stereoscopic 3D Display Type" is set at "ASUS 3D Vision laptop".
Click on "Test Stereoscopic 3D". Display resolution should be set at 1920 x 1080p,
and Refresh Rate set at 120 Hz. (Suggest you also tick "Apply this refresh rate to all games".)
Turn your 3D glasses on, then click "Launch Test Application". By then, you'll see the nVidia 3D demo.
When satisfied, press "esc" button.

If you want to turn off 3D Mode, it's best to do it via the nVidia Control Panel.
Just un-check "Enable Stereoscopic 3D", hit "Apply", then close it.

For all it's worth, the ROG button's 3D enable/disable functionality is only useful
during in-game. It does not actually function pre-game or post-game.




Oh, HDMI cannot be connected when you want to use the laptop screen for 3D,.

Does it mean 3D is working now on your native screen?
What nVidia driver version do you currently have on your G74?